Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Нахождение

10-11 класс

самого длинного слова в тексте.

Найти самое
длинное слово в тексте. Если таких слов несколько, то взять последнее.
Написать на Паскале



Allya14 12 янв. 2015 г., 14:45:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dvoe4nik123
12 янв. 2015 г., 16:50:49 (9 лет назад)

var
  x: array of string;
  y: string;

begin
  readln(y);
  x := y.Split(' ');
  y := x[0];
  foreach w: string in x do
    if (y.Length <= w.Length) then
      y := w;
  writeln(y);
end.

Ответить

Другие вопросы из категории

СРОЧНО!!!

1)Катя скачивает видеоклип из интернета в течение 3 минут. Качество связи при этом 512 Кбит/сек.
Вычислите информационный объем видеофрагмента и выразите его в мегабайтах. (Ответ - до сотых)

2)На каждой из 200 страниц книги содержится примерно 800 символов. Выразите в килобайтах

Читайте также

1)Составить алгоритм нахождения количества положительных элементов с последовательностью целых чисел b1, b2, b3, ..., bn 2)Составить алгоритм и

блок-схему нахождения произведения отрицательных чисел с последовательностью a1, a2, a3, ..., an

Составить функцию определения факта нахождения в одномерной матрице хоть одного нуля, состоящей из целых чисел и количеством элементов k. применить данную

функцию для нахождения номеров строк, произвольной матрицы, не содержащей нулей. Составить на языке паскаль.

Ребятки помогите!!!! 1.Написать программу нахождения периметра треугольника .Значение сторон вводятся с клавиатуры. 2. Написать программу

нахождения S прямоугольного треугольника. ЗНАЧЕНИЯ КАТЕТОВ ВВОДЯТСЯ С КЛАВИАТУРЫ!

ПОМОГИТЕ ЗАЙКИ,,,,,

Необходимо составить блок схему нахождения позиции буквы в слове.

Хотя бы объясните, что значит "нахождение позиции буквы в слове"?

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.



Вы находитесь на странице вопроса "Нахождение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.