Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

ввести выражение, которое заканчивается клавишей enter. определить, правльно ли расставлены круглые скобки. ПАСКАЛЬ

10-11 класс

барби90 26 июня 2014 г., 21:35:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Serovasvetlana1
26 июня 2014 г., 22:29:24 (9 лет назад)

var

  s:string;

  c1, c2, i:integer;

begin

  writeln('Введите строку');

  readln(s);

  c1 := 0;

  c2 := 0;

  for i := 1 to Length(s) do

  begin

    if s[i] = '(' then

      inc(c1);

    if s[i] = ')' then

    begin

      inc(c2);

      if c2 > c1 then

      begin

        writeln('Скобки расставленны неверно');

        exit;

      end;

    end;

  end;

  if c1 = c2 then

    writeln('Скобки расставлены верно')

  else

    writeln('Скобки расставленны неверно');

end.

Ответить

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

очень срочно.....помогите пожалуйста паскаль

Определить,можно ли сделать круглую заготовку с заданным радиусом R из квадратного листа фанеры с заданной стороной А. решить ее надо с помощью оператора выбора case

1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее

арифметическое.
2) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

ПОЖАЛУЙСТА ОБЪЯСНИТЕ САМО РЕШЕНИЕ.НЕ НАДО ПИСАТЬ ПРОГРАММУ. Определить есть ли в массиве хотя бы одна тройка соседних чисел, в которой

средний элемент больше своих "соседей", т. е. предшествующего и последующего. В случае положительного ответа определить номера элементов первой из таких троек.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "ввести выражение, которое заканчивается клавишей enter. определить, правльно ли расставлены круглые скобки. ПАСКАЛЬ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.