Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В этой задаче использовать case. Дано число. Если остаток от деления на 3 у него равен 1, то утроить, если остатка нет-учетверить.

5-9 класс

Letsz0ck3r 21 июля 2015 г., 7:30:10 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TD1777
21 июля 2015 г., 8:04:03 (8 лет назад)

спасибо ))))))))))))))

+ 0 -
Filipnv
21 июля 2015 г., 9:58:07 (8 лет назад)

Program dz;
var a,b : integer ;
Begin
writeln("Ввели число");
readln(a);
b:=a mod 3
case b of
if b = 1 then
b:=b*3;
else
b:=b*4;
end;
end.

Ответить

Другие вопросы из категории

1.Три брата — Ваня, Саша, Коля — учились в разных классах одной школы. Ваня был не старше Коли, а Саша — не старше Вани. Назовите имена старшего из

братьев, среднего и младшего.

2. На спортивной площадке лесного городка спортсмены построились в следующем порядке: заяц, белка, волк, лиса, лось, медведь. Главный судья енот предложил всем построиться по росту, начиная с самого высокого: лось, медведь, волк, лиса, заяц, белка. Разрешалось перестраиваться в ряду, меняясь места­ми, только рядом стоящими парами и переходить на новое место, проходя также пару рядом стоящих зве­рей. За какое наименьшее число таких переходов мож­но перестроиться по росту?

Какие типы алгоритмов соответствуют перечисленным видам деятельности? 1)Иван -царевич стоит на развилке трех дорог и,прочитав надпись на камне,выбирает

дальнейший путь. 2)мам готовит салат по рецепту. 3)ребенок играет. 4)карлсон съел все плюшки,которые принес ему малыш. А. последовательный алгоритм Б.циклический С.разветвленный алгоритм D.это невозможно представить в виде алгоритма Заранее спасибо!)

Читайте также

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Определить, делится ли первое число на другое без остатка.

Сначала строим информационную модель устно.

Во-первых, вводятся числа А и В.

Находим остаток от деления числа А на число В.

Если остаток от деления равен нулшю, то выводим результат: Число А делится на число В без остатка

Иначе

Результат – Число А делится на число В с остатком.

Существует метод шифрования - шифрование с помощью ключа. Ключом является слово "цель". Таким образом, результатом шифрования слова "информация" с помощью

этого ключа и с учетом того, что за исходный алфавит принят русский алфавит из 33 букв, будет слово "аублзтмуае" (необходимо сложить номера букв шифруемого слова и ключа, затем взять результат по модулю 33, т.е остаток от деления на 33) и сформировать шифрованное слова из букв с получившимся кодом). Например, при шифровании "информация+цельцельце" получим "и+ц", что соответствует 10+24=34=1 и букве 'a', "н+е", что соответствует 15+6=21 и букве 'у', и т.д. Какое слово было зашифровано, если в результате получено слово "жцхяёй"?



Вы находитесь на странице вопроса "В этой задаче использовать case. Дано число. Если остаток от деления на 3 у него равен 1, то утроить, если остатка нет-учетверить.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.