Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задание: какие значения получат переменные X и Y после выполнения следующего алгоритма ( на фотографии ). Я делал вот так:

5-9 класс

X=5

Y=-6

5=-12

Правильно ли?

Kovelka 09 авг. 2015 г., 18:58:28 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Larakondrashova
09 авг. 2015 г., 19:36:21 (8 лет назад)

я конечно сразу попробовал сделать в интерпретаторе:

x = -3 + 18/3
y = -6 - 12/3
x = 2*y
print (x..","..y)

 

Вывело  -20,-10

Можешь проверить тут: http://www.lua.org/cgi-bin/demo

Ответить

Другие вопросы из категории

Помогите срочно пожалуйста!Переведите на язык логических выражений следующие высказывания:1) я поеду в Москву,и если встречу там друзей ,то мы

интересно проведем время.2)если будет солнечная погода,то ребята пойдут в лес,а если будет пасмурная погода,то ребята пойдут в кино.3) неверно,что если дует ветер,то солнце светит тогда,когда нет дождя.4) если урок информатики будет интересным,то никто из школьников -Миша,Вика,Света-не будет смотреть в окно

Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае. а) Сумма цифр

трёхзначного числа х является чётным числом.

б) Треугольник со сторонами a, b, с являются равносторонним.

1.Три брата — Ваня, Саша, Коля — учились в разных классах одной школы. Ваня был не старше Коли, а Саша — не старше Вани. Назовите имена старшего из

братьев, среднего и младшего.

2. На спортивной площадке лесного городка спортсмены построились в следующем порядке: заяц, белка, волк, лиса, лось, медведь. Главный судья енот предложил всем построиться по росту, начиная с самого высокого: лось, медведь, волк, лиса, заяц, белка. Разрешалось перестраиваться в ряду, меняясь места­ми, только рядом стоящими парами и переходить на новое место, проходя также пару рядом стоящих зве­рей. За какое наименьшее число таких переходов мож­но перестроиться по росту?

Читайте также

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;

Помогите, пожалуйста, очень срочно. Желательно с полным решение. Заранее спасибо. 1) Определите значение целочисленных переменных a и b после выполнения

фрагмента программы: a := 3 + 8*4;
b := (a div 10) + 14;
a := (b mod 10) + 2; 2) Определите значение переменной c после выполнения следующего фрагмента программы:
a := 100
b := 30
a := a – b*3
if a > b then
c := a – b
else
c := b – a
еnd if

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4



Вы находитесь на странице вопроса "Задание: какие значения получат переменные X и Y после выполнения следующего алгоритма ( на фотографии ). Я делал вот так:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.