Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

кол-во непарных элементов массива

10-11 класс

const
n = 5;
var
a: array[1..n] of integer; i, c: integer;
begin
c := 0;
for i:=1 to n do
begin
readln(a[i]);
if mod(a[i])<>o then c:=c+1
end;
writeln(c);
end.
ему мод не нравится в условии=(
что делать?

Linda171 18 июля 2013 г., 12:58:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Граммота
18 июля 2013 г., 15:13:48 (10 лет назад)


const
n=5;
var
mas:array[1..n] of integer;
i,sum:integer;
begin
sum:=0;
for i:=1 to n do
begin
readln(mas[i]);
if mas[i] mod 2 = 0 then // Если mas[i] делиться на 2 без остатка,то...
sum:=sum+1;
end;
writeln(sum);
end.

+ 0 -
99kara
18 июля 2013 г., 17:49:50 (10 лет назад)

Что нужно в условии сравнить?

+ 0 -
Kor5v
18 июля 2013 г., 18:23:35 (10 лет назад)

мод используется так: число mod число (Выводит остаток от деления). Например 15 mod 10 = 5 (остаток от деления 15 на 10 = 5)

+ 0 -
Plhfdcndeqny1
18 июля 2013 г., 19:14:30 (10 лет назад)

в условии нужно найти кол-во непарных элементов массива, то есть тех элементов что делятся на 2 без остатка, спасибо за ответ^^

Ответить

Другие вопросы из категории

Читайте также

10 КЛАСС! ПАСКАЛЬ АБС!! СРОЧНО!! ПОМОГИТЕ ПОЖАЛУЙСТА! Дан массив А(n). Опередлите кол-во нечет элементов массиава, стоящих на

четных местах. выведите на экран исходный массив и найденное кол-во.

ан массив х(n).элементы массива,значения которых не принадлежат интервалу[A,B], разделить на 100 и подсчитать кол-во таких элементов. значения всех

остальных элементов возвести а квадрат.
помогите написать программы в паскале

составить программу 1)найти сумму всех элементов массива (1до10) random. 2)сформировать массив из положительных и отрицательных элементов

от -10 до 30.найти кол-во положит и отриц элементов.найти сумму положит и произведение отриц.



Вы находитесь на странице вопроса "кол-во непарных элементов массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.