Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано натуральное число N.Если число содержит 5 цифр,то получить новое число M,которое образуется путем исключения средней цифры исходного числа.Если

10-11 класс

количество цифр не 5,то M=N.

P.S - решить без использования строковой переменной.

Аришка00700 15 дек. 2016 г., 19:35:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikasinjakova
15 дек. 2016 г., 21:58:23 (7 лет назад)

uses crt;
var n,m:integer;
begin
readln(n);
if n div 1000>=10 then
m:=(n div 10000)*1000+((n div 1000)mod 10)*100+((n div 10) mod 10)*10+(n mod 10)
else m:=n;
writeln(m);
end.



Ответить

Другие вопросы из категории

напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность

символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Строка S не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

скласти програму привітання з ПК,у вікні виконання матимемо:

привіт,я ПК
як тебе звати?
(імя)
(імя),мені дуже приємно з вами познайомитися

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Решите головоломку.Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Причем: А - фрагмент

оперативной памяти размером в 16 байтов; В – конечное число точек на плоскости, соединённых отрезками кривых линий; С – единица измерения расстояния; Д – аргумент или результат процедуры.В ответе запишите найденные слова: сначала А, затем, В, С и Д, через один пробел, без знаков препинания.

Переведите на язык логических выражений следующие высказывания: 1) я поеду в Москву,и если встречу там друзей ,то мы интересно проведем

время.

2)если будет солнечная погода,то ребята пойдут в лес,а если будет пасмурная погода,то ребята пойдут в кино.

3) неверно,что если дует ветер,то солнце светит тогда,когда нет дождя.

4) если урок информатики будет интересным,то никто из школьников -Миша,Вика,Света-не будет смотреть в окно.:)



Вы находитесь на странице вопроса "Дано натуральное число N.Если число содержит 5 цифр,то получить новое число M,которое образуется путем исключения средней цифры исходного числа.Если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.