Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан массив из целых чисел. В массиве есть повторяющиеся числа.Вывести сколько раз встречается каждый элемент массива.

10-11 класс

Sicorashka 08 окт. 2014 г., 6:19:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Milenasa
08 окт. 2014 г., 6:51:32 (9 лет назад)

const
  U=1000;
type:
  Mas= array [1..U] of integer;
var
  a: Mas;
  i,j,k,n: integer;
begin
  read(n);
  for i:=1 to n do
    read(a[i]);
  for i:=1 to n do
  begin
    k:=0;
    for j:=1 to n do
    begin
      if a[i]=a[j] then k:=k+1;
    end;
    write(k,' ');
  end;
  readln;
  readln
end.
Если понравилось поставь лучшее решение!
Спасибо!

+ 0 -
Ahtu63
08 окт. 2014 г., 9:50:35 (9 лет назад)

Программу написать ? Или что?

Ответить

Другие вопросы из категории

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.

привет всем)помогите пож-та с задачей. Найти и распечатать строку заданной целочисленной матрицы размером 10х10, в которой длина максимальной серии

минимальна. (Серия-последовательность одинаковых элементов. Длина серии-количество одинаковых элементов) .(паскаль) очень очень нужно))) заранее спасибо))

Программа Exel

Какую функцию можно использовать в пункте 4?

В ответ запишите одно слово.

Каким термином называется концептуальная структура персонального
компьютера, от которой зависит каким образом, будет проводиться обработка
информации, то есть ее преобразование в данные, а также принципы взаимодействия
технических средств и программного обеспечения? Это понятие в широком смысле
определяется как искусство проектирования различных сооружений.

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Дан массив целых чисел. Выяснить:

1) верно ли, что сумма массива есть честное число;
2)верно ли, что сумма квадратов элементов массива есть пятизначное число.

Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.

Один элемент массива соответствует количеству очков, набранных одним участником соревнований, и имеет значение от 0 до 30 включительно. Необходимо разработать программу, которая по данным массива вычисляет максимальное количество очков среди участников соревнований, и количество участников набравшее зачётное количество очков. Зачётное количество очков 18. Гарантируется, что хотя бы один участник соревнований набрал зачётное количество очков.



Вы находитесь на странице вопроса "Дан массив из целых чисел. В массиве есть повторяющиеся числа.Вывести сколько раз встречается каждый элемент массива.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.