Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны 2 целых числа a, b. Вычислить сумму чисел, находящихся между этими числами.

10-11 класс

Milllka2013 02 сент. 2013 г., 16:00:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mhitaryankrist
02 сент. 2013 г., 17:28:15 (10 лет назад)

var
  a, b, s, i: integer;

begin
  Write('Введите через пробел значения a,b (b>a) ->');
  Readln(a, b);
  if a > b then begin s := a; a := b; b := s end; {от дураков}
  s := 0;
  for i := a + 1 to b - 1 do
    s := s + i;
  Writeln('Сумма равна ', s)
end.

Тестовое решение:

Введите через пробел значения a,b (b>a) ->3 8
Сумма равна 22



+ 0 -
Mariakyazhina
02 сент. 2013 г., 19:47:04 (10 лет назад)

Программа или алгоритм (блок-схема).? Если программа - какой язык?

+ 0 -
Antoninasmile
02 сент. 2013 г., 22:34:34 (10 лет назад)

программа.. язык паскаль

Ответить

Читайте также

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ



Вы находитесь на странице вопроса "Даны 2 целых числа a, b. Вычислить сумму чисел, находящихся между этими числами.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.