Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПАСКАЛЬ Дано число. Дать характеристику числа:

5-9 класс

положительное, отрицательное;
чётное, нечётное;
целое, не целое.

Slaaaaag 16 апр. 2014 г., 12:54:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Erlan87967867867
16 апр. 2014 г., 14:05:03 (10 лет назад)

var a:real; k,m,p:string;
Begin writeln('Введите число'); readln(a);
if a<0 then k:='отрицательное' else k:=' положительное';
if a=int(a) then m:=' целое' else m:='не целое';
if a/2=int(a/2) then p:=' чётное' else p:=' нечётное ';
writeln('число ',a,' - ',k,' ; ',m,' ; ',p);
end.

Ответить

Другие вопросы из категории

1) Скорость передачи данных по некоторому каналу связи равна 512 Кбит/с. Передача файла по этому каналу связи заняла 4 мин. Определите размер файла в

мегабайтах.

2) Скорость передачи данных по некоторому каналу связи равна 32 Кбит/с. Передача текстового файла по этому каналу связи заняла 15 с. Определите, сколько страниц содержал переданный текст, если известно, что иформационный вес одного символа равек 8 битам, а на одной странице 48 символов.

3) Скорость передачи данных по некоторому каналу равна 64000 бит/с. Передача файла по этому каналу связи заняла 16 с. Определите размер файла в килобайтах.

хотя бы первую решите....

С пояснениями пожалуйта .. Буду очень признательна

0,12 мб в килобайты

0,001гб в байты

1.

что не является устройством вывода информации ?
а) наушники
б) микрофон
в) проектор
г) принтер
2.
что не является ввода графической информации ?
а) сканер
б) мышь
в) графический планшет
г) монитор

Срочно!!!!!!!!!!

Есть ли какой нибудь тип на Паскале, отвечающий за строки длины <=10000 (то есть не string)
Пожалуйста!!!!!!!!!!1

Читайте также

Дано число, дать характеристику числа:

а) положительное или отрицательное
б)четное или нечетное

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

помогите пож-а))) 5. Есть исполнитель «Арифмометр», который понимает следующие команды: - взять число N

(занести в память число N),

- умножить (перемножаются занесённые в память последние два числа),

- сложить (складываются занесённые в память последние два числа),

- вычесть (вычисляется разность занесенных в память последних двух чисел),

- результат (вывести результат)

Например, в результате выполнения алгоритма:

- взять число 5,

- взять число 10,

- взять число 2,

- вычесть,

- умножить,

- результат

получим ответ 40, так как 5*(10-2)=40.

Какой результат будет получен при выполнении приведённого ниже алгоритма?

- взять число 4,

- взять число 8,

- взять число 2,

- вычесть,

- взять число 10,

- умножить,

- взять число 56,

закодировать значение числа в двоичную систему а)число 117 б)число 217 в) число 317

женя готовил доклад по литературе. в докладе 12 строчек,в каждой строчке 22 символа. определить количество информации а)в 1 символе 7 бит б) в 1 символе 10 разрядов двоичного кода.
пожалуйста помогите



Вы находитесь на странице вопроса "ПАСКАЛЬ Дано число. Дать характеристику числа:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.