Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ввести массив H [1..5] и число А.Для каждого элемента массиа вычислить Z= корень из Ht/A.Исходный массив и результат распечатать.

10-11 класс

настя80224331273 20 нояб. 2014 г., 11:53:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alona2027
20 нояб. 2014 г., 14:32:22 (9 лет назад)

program zadacha;
uses crt;
var a, i: integer;
z: real;
h: array [1..5] of integer;
begin
clrscr;
write ('vvedite chislo A: ');
readln (a);
for i:=1 to 5 do begin
write ('vvedite elemeny massiva H: ');
readln (h[i]);
z:=sqrt(h[i]/a);
writeln ('H[i]=',h[i], ' Z=', z:0:4);
end;
readkey;
end.

или 

program zadacha;
uses crt;
var a, i: integer;
z: real;
h: array [1..5] of integer;
begin
clrscr;
write ('vvedite chislo A: ');
readln (a);
for i:=1 to 5 do begin
write ('vvedite elemeny massiva H: ');
readln (h[i]);
end;
for i:=1 to 5 do begin
z:=sqrt(h[i]/a);
writeln ('H[', i, ']=',h[i], ' Z=', z:0:4);
end;
readkey;
end.



Ответить

Другие вопросы из категории

Решить в C++

S=1+3+5+7+ …, всего n слагаемых

помогите исправить ошибки.Масиви. Уплотнить линейный массив, удалив нули и сдвинув влево остальные элементы program

{ Уплотнить линейный массив удалив нули и сдвинув влево остальные элм.}

uses crt

var m,i,k:longint a:array[1..100]of longint

begin

clrscr

write('введите кол-во элм таблицы: ')redln(k)

for i=1 to k do

begin

write('a[',i,']=')redln(a[i])

end

m=0

for i=1 to k do

if a[i]=0 then inc(m)

elsey a[i-m]=a[i]k=k-m

for i=1 to k do write(a[i],' ')redln

end.

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

Uses crt;

type mas=array[1..98] of integer;
var A,F,Q,C:mas;
i,s:integer;
begin
clrscr;
writeln('Массив первый:');
for i:=1 to 98 do
begin
A[i]:=random(100)-2;
write(A[i]:4);
end;
writeln;
writeln('Массив второй :');
for i:=1 to 98 do
begin
F[i]:=random(100)-2;
write(F[i]:4);
end;
writeln;
writeln('Массив третий :');
for i:=1 to 8 do
begin
Q[i]:=random(60)-52;
write(Q[i]:4);
end;
writeln;
writeln('Массив четвертый:');
for i:=1 to 8 do
begin
C[i]:=(sqrt(A[i])+sqrt(F[i]))/2+sin(A[i]*F[i])+(sqrt(Q[i])+sqrt(F[i]))/2+sin(Q[i]*F[i])+(sqrt(A[i])+sqrt(Q[i]))/2+sin(A[i]*Q[i]);
write(C[i]:4);
end;
writeln;
end.

Даны массивы A98), F98),Q(8). Сформировать массивы С(8), каждый элемент которого вычисляется по формулеC[i]:=(sqrt(A[i])+sqrt(F[i]))/2+sin(A[i]*F[i])+(sqrt(Q[i])+sqrt(F[i]))/2+sin(Q[i]*F[i])+(sqrt(A[i])+sqrt(Q[i]))/2+sin(A[i]*Q[i]);

Вычисление по формуле (x^2+y^2)/2+sin(X*Y) оформить в виде подпрограммы.



Вы находитесь на странице вопроса "Ввести массив H [1..5] и число А.Для каждого элемента массиа вычислить Z= корень из Ht/A.Исходный массив и результат распечатать.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.