Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста, хотя бы одно задание!!!

5-9 класс

Kirnitskiysasha 27 окт. 2015 г., 0:42:04 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marisol14
27 окт. 2015 г., 2:26:13 (8 лет назад)

var
  a : array [1..10] of integer;
  i, k : integer;
begin
  write ('Before : ');
  for i := 1 to 10 do
  begin
    a[i] := random(21) - 10;
    write (a[i], ' ');
  end;


  for i := 1 to 10 do
    if a[i] mod 2 = 0 then
      a[i] := a[i] div 2
    else
      a[i] := a[i] - 4;
      
   writeln;
   write ('after A: ');
   for i := 1 to 10 do
     write (a[i], ' ');   
      
   for i := 1 to 10 do
     if a[i] < 0 then a[i] := a[i] * a[i] * a[i]
     else a[i] := round(sqrt (a[i]));
     
   writeln;
   write ('after B: ');
   for i := 1 to 10 do
     write (a[i], ' ');  
     
   for i := 1 to 10 do
     if a[i] mod 5 = 0 then a[i] := a[i] * 2
     else a[i] := a[i] mod 3;
   
   writeln;
   write ('after C: ');
   for i := 1 to 10 do
     write (a[i], ' ');
   
   k := a[2];
   a[2] := a[9];
   a[9] := k;   
   
   writeln;
   write ('after D: ');
   for i := 1 to 10 do
     write (a[i], ' ');
 end.

+ 0 -
Jxcjxkf
27 окт. 2015 г., 5:18:03 (8 лет назад)

надо все подпункты в одной программе?

+ 0 -
Vichkay
27 окт. 2015 г., 8:00:34 (8 лет назад)

да!!

Ответить

Другие вопросы из категории

Помогите плиз Составить программу вычисления значений функции F(x) на отрезке

[a,b] с шагом h. Результат представить в виде таблицы, первый столбец которой – значения аргумента, второй – соответствующие значения функции:

F(x)=sin x – cos x

1)Перевести 30, 29, 28, … , 10 м в сантиметры

2)Вычислить х*у, используя лишь операцию сложения
3)Рассчитайте плотность популяции белок за 1, 2, 3, …, 12 лет, если их первоначальная численность составила 552 особи на 1400 км2, ежегодный прирост составляет 20%
pascal abc

Читайте также

информационное сообщение объёмом 1 Мбайт передается со скоростью 4 Кб/мин.определите время передачи информации.

и еще одно задание:

сколько Кб информации содержат сообщения следующего объёма? :

2^16 бит, 2^16 байт и 1/4 Мб. Помогите решить хотя бы одно задание!!!!

ПОМОГИТЕ ПОЖАЛУЙСТА!! СРОЧНО!! ХОТЯ БЫ ОДНО ЗАДАНИЕ!!

Первое задание:
Постройте электронную таблицу (в excel) «Оплата электроэнергии» для расчета ежемесячной платы за расход электроэнергии в течение года. Исходной информацией являются показания счётчика в начале каждого месяца и стоимость одного киловатт-часа.
Второе задание:
В таблице "Оплата электроэнергии" из предыдущего задания используйте абсолютный адрес для ячейки, хранящей стоимость 1 кВт*ч электроэнергии.

Помогите пожалуйста. Очень прошу) Заранее благодарна)

Дана программа:
Program p1;
var a:integer.
begin
write('Введите целое число:');
readln(a);
if(a>=100) and (a<1000)then write(' Да')
else write(' Нет');
End.
1.Запишите, что будет выведено на экране в результате выполнения данной в п.1 программы. при=-2, при а=123.
2. Внести данную программу изменения таким образом, чтобы программа определяла, удовлетворяет ли данное вещественное число а неравенству -14,5 < a <_ 18,
3. Даны целые числа a и b. Составьте программу, определяющую, есть ли среди них хотя бы одно, не равное нулю.
4. Ввести три целых числа. Если ни одно из чисел не является чётным, то вывестина экран их произведение.
Тема с Packal ABC.

Решите,пожалуйста,хотя бы одну из данных задач:

1)Написать программу,подсчитывающую сумму положительных из трех данных чисел.
2)Напечатать те из двузначных чисел которые делятся на 4,но не делятся на 6.
СРОЧНО!!!



Вы находитесь на странице вопроса "Помогите пожалуйста, хотя бы одно задание!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.