Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста . Дано целое число N(>0). Сформировать и вывести целочисленный массив размера N, содержащий степени двойки от первой до

1-4 класс

N-й:2,4,8,16.....

Dasha192563 25 янв. 2017 г., 16:57:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marat0564
25 янв. 2017 г., 18:03:41 (7 лет назад)

Сделал через динамический массив и без модуля Math
var i,n:integer;    a:array of real;
begin 
Readln(n); 
SetLength(a,n); 
for i:=0 to Length(a) do   
a[i]:=Exp(Ln(2)*i); 
for i:=0 to Length(a) do   
writeln('2^',i,' = ',a[i]); 
Readln;
end.

Ответить

Читайте также

Даны два целых числа - координаты точки в декартовой системе координат. Определить, в какой четверти находится точка.

Входные данные:
Во входном потоке заданы два целых ненулевых числа, значение которых по модулю не превышают 30000.

Выходные данные:
В выходной потов вывести единственное целое число.

Пример входного файла
3 9

Дано целое число i.

найти значение a,
где a=i^3, если i кратно 5
a=i^2, если i кратно 2.
a=2*i+1 в остальных случаях.

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
5 4 5
Пример выходного файла
YES

помогите вопрос такой: нужно составить порядок действий при создании информационной модели действия такие: проверить соответствие модели

объекту-оригиналу , выбрать способ предстовленния информации (текст, рисунок, таблица, схема, диаграмма Эйлерра-Венна) , опредилить цель создания модели, рассмотреть объект-оригенал и назвать существенные свойства с точки зрения цели моделирования, создать информационную модель( составить описание, таблицу, нарисовать схему, диаграму или рисунок) помогите пожалуйсто

При передаче данных по сети они шифруются так, что объём информации увеличивается на 40 % .Передача одного такого сообщения заняла 28 секунд при

скорости передачи информации 1, 25 Мб/c . Определите исходный объём данных в Мб
Помогите пожалуйста решить задачу



Вы находитесь на странице вопроса "помогите пожалуйста . Дано целое число N(>0). Сформировать и вывести целочисленный массив размера N, содержащий степени двойки от первой до", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.