Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано целое число i.

1-4 класс

найти значение a,
где a=i^3, если i кратно 5
a=i^2, если i кратно 2.
a=2*i+1 в остальных случаях.

Nervnayu 07 янв. 2015 г., 12:28:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
YourFunnyHoney
07 янв. 2015 г., 14:25:45 (9 лет назад)

var  i, a:integer;
begin
   readln(i);
   if i mod 5=0 then a:=i*i*i else 
    begin
    if i mod 2=0 then a:=i*i else a:=2*i+1;
    end;
    writeln(a);
    end.

Ответить

Другие вопросы из категории

Подбери слова-действия, подходящее по смыслу в каждой строке.Объясни выбор.

а)сканер,рисунок...............
б)принтер,изображение...........
в)клавиатура,символ.......
г)телефон,сигнал......

Какие бывают коды?

Ну например графические .... Какие ещё?

дополни схему названиями составных частей

и их признаками.
ЦВЕТОК
ПРИЗНАКИ
КОЛИЧЕСТВО ЛЕПЕСТКОВ
КОЛИЧЕСТВО ЛИСТЬЕВ
___________
ПРИЗНАКИ
_______________
........
ПРИЗНАКИ
.........
___________________
ПРИЗНАКИ
____________

Читайте также

Даны два целых числа - координаты точки в декартовой системе координат. Определить, в какой четверти находится точка.

Входные данные:
Во входном потоке заданы два целых ненулевых числа, значение которых по модулю не превышают 30000.

Выходные данные:
В выходной потов вывести единственное целое число.

Пример входного файла
3 9

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
5 4 5
Пример выходного файла
YES

PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в

интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.



Вы находитесь на странице вопроса "Дано целое число i.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.