Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В колбе n бактерий.В какой-то момент времени в колбу попадает вирус.В первую минуту он уничтожает одну бактерию,после чего вирус и бактерии делятся в кажду

10-11 класс

ю следующую минуту вирусы уничтожают по одной бактерии и снова делятся.Через сколько минут вирусы уничтожат все бактерии? Нужно привести решение в Паскале.Очень срочно!

Shadysl 09 марта 2015 г., 3:56:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chukona
09 марта 2015 г., 5:52:46 (9 лет назад)

var b, v, t:integer;begin     write('Skolko bilo bakteriy?'); readln(b);     v := 1;     t := 0;     while b > 0 do     begin          b := b - v;          b := b * 2;          v := v * 2;          t := t + 1;     end;     writeln(t);end.

Ответить

Другие вопросы из категории

Помогите написать программу)))

Задано трехзначное число, определить:
1) сумму цифр этого числа;
2) произведение;
3) минимальную цифру;
4) максимальную цифру этого числа.

Читайте также

Два товарища Миша и Петр пошли в тир. Они стреляют по мишенях, которые расположены в один ряд. Миша стреляет по мишенях с лева направо, а Петр с права

налево.В какой то момент времени случилось так, что они попали в одну мишень. После этого они остановились и решили посчитать, во сколько мишеней каждый из них не стрелял. М и Р - количество мишеней, в какие попали Миша и Петр соответственно.
М+Р меньше или равняется 100
Нужно найти два числа - количество мишеней в какие не стреляли Миша и Петр.

какая информация хранится в оперативной памяти? *

та, с которой работает процессор в данный момент времени
та, которая нужна для тестирования компьютера
та, которая сохраняется после выключения компьютера

Помогите решить пожалуйста!!! Циклический оператор на ЯП Паскаль: Каждая бактерия делится на две в течение

одной минуты.

В начальный момент времени имеется одна бактерия.

Составьте программу, которая рассчитывает количество бактерий на заданное пользователем с клавиатуры целое значение момента времени (15 минут, 7 минут и т.п.)

Два друга - Иван и Дима - вместе используют канал доступа в Интернет с

пропускной способностью 4 Кбайт в секунду. Система балансировки нагрузки
настроена таким образом, что если в данный момент времени канал
использует только один человек, то скачивание файла происходит со
скоростью равной пропускной способности канала, а если канал используют
оба друга - пропускная способность канала поровну делится между
пользователями.
Иван начал скачивать музыкальную композицию. Через 16
секунд Дима начал скачивать графический файл. Иван закончил скачивать
музыкальную композицию через 1 мин 8 секунд от начала скачивания своего файла.
Для
музыкальной композиции производится одноканальная (моно) звукозапись с
частотой дискретизации 128 Гц. При записи использовались 16 уровней
дискретизации. Графический файл содержал 16384 пикселей, кодированных с
использованием палитры из 256 цветов. И в файле с музыкальной композиции
и графическом файле не использовалось сжатия данных. Кроме упомянутых
скачиваемых файлов другой нагрузки на канал доступа в интернет не было.
Сколько секунд длиться музыкальная композиция которую скачал Иван? В
ответе укажите целое число секунд. Единицы измерения в ответе не
указывать.

Pascal составить прграмму .

Работа светофора запрограммирована таким образом : в начале каждого часа 3 минуты горит зелёный свет , затем 2 минуты красный , затем 3 минуты зелёный и т.д . Дано время t в минутах от начала часа . Определить сигнал какого цвета горит в этот момент времени для пешехода .



Вы находитесь на странице вопроса "В колбе n бактерий.В какой-то момент времени в колбу попадает вирус.В первую минуту он уничтожает одну бактерию,после чего вирус и бактерии делятся в кажду", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.