Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите решить.. с объяснением Найдите наибольшее целое отрицательное число Х, при котором истинно высказывание

10-11 класс

Lika1 07 марта 2015 г., 3:08:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dmkurin
07 марта 2015 г., 4:50:58 (9 лет назад)

Как извесно, в информатике следование равяется нулю тогда, когда 1 член равен 1, а второй член равен 0. В остальных же случаях следвание равняется 1. Отсюда методом подбора берем любые целые отрицательные числа, при которых будет выражение истинно.

Сначала возьмем число -5. Подставим

 

-5*-5 =25>15 Следовательно это истоинно и равно 1
(-5+1)*(-5-1)=24<26 Следовательно это тоже равняется 1

Из этого следует, что выражение истинно(1->1=1)

 

Теперь попробуем взять число -6

-6*-6=36>15 Отсюда это истоинно и равно 1

(-6+1)*(-6-1)=35>26 Отсюда жто ложно и значит равняется 0

Из этого следует, что выражение ложно (1->0=0)

 

Отсюда можно сделать вывод, что дальше -5 числа не смысла брать т.к. в этом случае выражение будет равняться 0, а ниже -5 потому что нам нужно наибольшее целое отрицательное, следовательно наш ответ -5

 

Ответ: -5

Ответить

Другие вопросы из категории

Помогите написать программу)))

Задано трехзначное число, определить:
1) сумму цифр этого числа;
2) произведение;
3) минимальную цифру;
4) максимальную цифру этого числа.

Читайте также

Каково наибольшее целое число X, при котором истинно высказывание? 1) (90 < X•X) → (X < (X-1)) 2) (X•X - 1 > 100) → (X•(X-1)< 100) 3) (X•(X+

1) > X•X + 7) → (X•(X+1) ≤ X•X + 7) 4) (X•X - 7 > 15) → (X•X + 8 < 35) A) 7 B) 9 C) 10 D) 5

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти

величину наибольшего среди отрицательных чисел этой последовательности.



Вы находитесь на странице вопроса "Помогите решить.. с объяснением Найдите наибольшее целое отрицательное число Х, при котором истинно высказывание", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.