Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. ЦИКЛ while

10-11 класс

Nara12094 23 июля 2013 г., 11:31:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natistomina201
23 июля 2013 г., 12:30:05 (10 лет назад)

While:

Program TaskA;
Var i: Integer;
Begini := 1;
While i < 1024 Do
Begin
i := i * 2;
Write(i, ' ');
End;
End.

Program TaskB;
Var i, a: Integer;
Begin
i := 1;
While i < 21 Do
Begin
a := a + i;
i := i + 1;
Write(a, ' ');
End;
End.

Program TaskC;
Var i, sum: Integer;
Begin
While sum < 100 Do
Begini := i + 1;
sum := sum + i;
Write(i, ' ');
End;
End.

Random:

Program TaskA;
Begin
Randomize;
WriteLn(Random);
End.

Program TaskB;
Begin
Randomize;
WriteLn(Random(10) + 1);
End.

Program TaskC;
Begin
Randomize;
WriteLn(Random(20 + 1) - 10);
End.

Program TaskD;
Begin
Randomize;
WriteLn(Random(51) * 2);
End.

Program TaskE;
Begin
Randomize;
WriteLn(Random(50) * 2 + 1);
End.

+ 0 -
Marisha2014
23 июля 2013 г., 15:17:02 (10 лет назад)

B Pascal ABC

Ответить

Другие вопросы из категории

Сравнить два числа с плавающей запятой 495,3*10^-11 и 0,0000478*10^-4

Как это сделать?

Читайте также

Составление таблицы функции y=a³/(a²+x2) для x , принадлежащих отрезку [-1;1] с шагом 0.1. Так как пример цикла типа for должен быть целочисленным ,

удобнее использовать цикл while, в котором значение x можно изменять при каждом шаге на Dx=0.1

Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных

в одномерный целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность
массива).

Напишите программу для pascal

в цикле while присвоить случайные значение элементам массива вывести на экран элементы значение которых не превышают 3,2

Как исправить for на цикл while?????

var n,k,i,t:integer; f:text;
begin
assign(f,'f1.txt');
rewrite(f);
readln (n);
for i:=2 to n do begin
t:=0;
for k:=2 to n do
if i mod k=0 then t:=t+1;
if t=1 then write(f,i:3);
end;
close(f);
end.



Вы находитесь на странице вопроса "1. ЦИКЛ while", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.