Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Как исправить for на цикл while?????

10-11 класс

var n,k,i,t:integer; f:text;
begin
assign(f,'f1.txt');
rewrite(f);
readln (n);
for i:=2 to n do begin
t:=0;
for k:=2 to n do
if i mod k=0 then t:=t+1;
if t=1 then write(f,i:3);
end;
close(f);
end.

настюша27 13 июня 2013 г., 21:12:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dima123701
13 июня 2013 г., 23:19:14 (10 лет назад)

после readln(n);
пишем:
i:=2;
while i<=n do begin
t:=0;
i:=i+1;
end;
k:=2;
while k<=n do begin
if i mod k=0 then t:=t+1; 
if t=1 then write(f,i:3);

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!
Сделайти пожалуйста умоляю срочно

Выполнить вычитание
а) 1011110110(2) - 1001011001(2)
б) 1101101110(2) - 1000111000(2)
в) 1101110010,01(2) - 111110110,01(2)
г) 1653,1(8) - 415,6(8)
д) 1В9,4(16) - 1В4,6(16)

Читайте также

решите задачки пожалуйста ( задачки должны быть на цикл while) 1. Вклад в банке составляет x рублей. Ежегодно он увеличивается

на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

2. Дано натуральное число

Составление таблицы функции y=a³/(a²+x2) для x , принадлежащих отрезку [-1;1] с шагом 0.1. Так как пример цикла типа for должен быть целочисленным ,

удобнее использовать цикл while, в котором значение x можно изменять при каждом шаге на Dx=0.1

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5



Вы находитесь на странице вопроса "Как исправить for на цикл while?????", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.