Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите пожалуйста)))Написать программу, которая вводит n чисел и положительные числа выводит на экран.

5-9 класс

79619890107 19 нояб. 2013 г., 12:08:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andesixxx
19 нояб. 2013 г., 12:39:47 (10 лет назад)

const: n={количество чисел}
var A: array [1..n] of integer;
i : integer;
begin
for i:=1 to n do
read(A[i]);
for i:=1 to n do
if A[i] >0 then write(A[i]);
end.

или без массива
var i, n, c : integer;
begin
read(n); {количество чисел}
for i:=1 to n do
  begin
  read(c);
  if c>0 then write(c);
  end;
end.

Ответить

Другие вопросы из категории

Номер 1:

Даны основание а и периметр Р равнобедренного треугольника.Составь программу определяющую боковые стороны треугольника
Номер 2:
Даны боковая сторона С и периметр Р равнобедренного треугольника.Составь программу определяющую основание этого треугольника.
ПОМОГИ ПОЖАЛУЙСТА

петя и Вася игрунковы лыбят играть в стрелялки .на начальном этапе к них по 10 патронов на брата .ВАСЯ УЖЕ УСПЕЛ ПОТРАТИТЬ НЕКОТОРОЕ КОЛИЧЕСТВО

ПАТРОНОВ. А ПЕТЯ ПОТРАТИЛ СТОЛЬКО СКОЛЬКО ОСТАЛОСЬ У БРАТА. СКОЛЬКО ВСЕГО В СУММЕ ОСТАЛОСЬ ПАТРОНОВ У БРАТЬЕВ .А)5 б)10 в)12 г)15

Помогите найти НОК чисел 90,30 и 28!

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!



Вы находитесь на странице вопроса "помогите пожалуйста)))Написать программу, которая вводит n чисел и положительные числа выводит на экран.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.