Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное

10-11 класс

среди них.Ничего кроме этого программа выводить не должна. При использовании системы Free Pascal для представления целых чисел используйте тип LongInt. Надо сделать в Pascal

Надият 30 окт. 2014 г., 21:03:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
дамир4713
30 окт. 2014 г., 23:58:39 (9 лет назад)

var

  a, b, c, d, t1, t2:longint;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  write('c = '); readln(c);

  write('d = '); readln(d);

  if a < b then

    t1 := a

  else

    t1 := b;

  if c < d then

    t2 := c

  else

    t2 := d;

  if t1 < t2 then

    writeln('Min = ', t1)

 else

    writeln('Min = ', t2);

  readln;

end.

 

+ 0 -
Pika4y43
31 окт. 2014 г., 1:34:58 (9 лет назад)

var

a,b,c,d,max:longint;

begin

  read(a); read(b); read(c); read(d);

  min:=a;

  if min>b then min:=b;

  if min>c then min:=c;

  if min>d then min:=d;

  writeln(min);

end.

 

Программа работает, проверено мной.)

Ответить

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

Объясните как делать : составить программу которая сравнивает два числа

введенные с клавиатуры и выводит на экран большее .

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0



Вы находитесь на странице вопроса "Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.