Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Как найти произведение элементов 4 столбца?Турбо паскаль

5-9 класс

program sbb;

uses crt;

var

i,j,s:integer;

a:array[1..5,1..10] of integer;

begin

for i:=1 to 5 do

begin

for j:=1 to 10 do

begin

random(50);

a[i,j]:=random(50);

write(' ');

write(a[i,j]);

end;

writeln

end;

Elvira9887766554 27 нояб. 2014 г., 2:31:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oksanamaxova57
27 нояб. 2014 г., 4:03:35 (9 лет назад)

Proizv:=1;
I:=4;
For j=1 to 10 do
Proizv:=proizv*a[i,j];

+ 0 -
Slow123
27 нояб. 2014 г., 4:57:42 (9 лет назад)


s:=1;
for i:=1 to 5 do
 s:=s*a[i,4];

{в s произведение 4 столбца}

Ответить

Другие вопросы из категории

Во время экзамена по информационным технологиям два члена

экзаменационной комиссии, не знакомые школьнику, предложили ему
выбрать один из двух билетов: трудный или легкий. Преподаватели
практиковали различные системы обучения.
Один - на вопрос ученика всегда давал правдивый ответ.
Второй - всегда предлагал ученику неправильный ответ (лгун), чтобы убедиться в твердости его знаний.
Какой вопрос должен задать ученик любому преподавателю, чтобы выбрать легкий билет?

Два соседа, Петя и Вася, учатся в одном кружке. Им дали задание написать сочинение, набрать его в текстовом редакторе и отправить преподавателю. У Ва

си в два раза больше символов в сочинении. Для отправки сочинений каждый из ребят использует каналы связи с различной скоростью передачи данных. У Пети скорость передачи данных 2 КБайт/с, а у Васи - 8 КБайт/с. Петя использовал при написании сочинения 2-х байтную таблицу символов Unicode. Для отправки его сочинения потребовалось 64 секунды. Сколько байт требуется для кодирования одного символа в таблице символов Васи, если известно, что на отправку его сочинения ушло 16 секунд. Считается, что при отправке сочинения никакой служебной информации не передается, а файл сочинения также не содержит служебной информации. В ответе запишите целое число байт.

Читайте также

Очень нужна помощь. Помогите найти ошибки - Паскаль.

Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами.

Не совсем то выводит, и модуль может как-то через abs надо.

program proizvedenie;
var q,z,w,i,n,i1,i2:integer;
a:array[1..1000] of real;
amin,amax,pr:real;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
amin:=a[1];
for i:=1 to n do
begin
if a[i]<amin then
begin
amin:=a[i];
i1:=i;
end;
end;
amax:=a[1];
for i:=1 to n do
begin
if a[i] > amax then
amax:=a[i];
i2:=i;
end;
if i2>i1 then begin
q:=i1;
w:=i2;
end
else begin
q:=i2;
w:=i1;
end;
if (w-q)>1 then begin
pr:=1;
for z:=q to w do
pr:=pr*a[z];
end
else write (0);
close (input);
close (output);
end.

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.



Вы находитесь на странице вопроса "Как найти произведение элементов 4 столбца?Турбо паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.