Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить подпрограмму которая из матрицы F(k,m) K меньше либо равно 25,m меньше или равно 20 удаляет строку, содержащую минимальный элемент всей

10-11 класс

матрицы. Глобальных переменных не использовать. В основной программе ввести исходные данные, с помощью подпрограммы получить результат и вывести матрицу до и после преобраз

срочно за деньги!!!

Alinatonkih 26 окт. 2014 г., 4:32:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ilnaz112
26 окт. 2014 г., 7:09:22 (9 лет назад)

Пардоньте, прослоупочил про подпрограммы)

uses crt;
var
a:array[1..25,1..20] of integer;
i,j,min,k,n,m:integer;
procedure input_array(n,m:integer; var a:array[1..25,1..20] of integer);
var i,j:integer;
begin
randomize;
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(101)-50;
write(a[i,j]:4);
end;
writeln;
end;
end;
procedure del(n,m,min,k:integer;a:array[1..25,1..20] of integer);
var i,j:integer;
begin
for i:=1 to n do
begin
if i=k then i:=i+1;
for j:=1 to m do
write(a[i,j]:4);
writeln;
end;
end;

begin
read(n,m);
input_array(n,m,a);
min:=a[1,1];
for i:=2 to n do
for j:=1 to m do
if a[i,j]<min then begin min:=a[i,j]; k:=i; end;
writeln; writeln;
del(n,m,min,k,a);
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ!!!

Перевести число в десятичную систему: 1Е9,4 в шестнадцатиричной
Выполнить умножение столбиком: 1100110*110010 в двоичной
Выполните деление столбиком; 1110010000:10000 в двоичной

Читайте также

Люди помогайте!!!))) Паскаль!!!

1)Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

2)Составьте программу заполнения массива из десяти чисел следующими значениями
а) 2 4 6 8 10 (+ 2)
б)3 6 9 12 15 (+3)

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

1.составить программу которая в введенном тексте удаляет пробелы 2.составить программу которая в ведённом тексте после пробелов ставит две буквы

к

3.составить прогу которая находит индекс последней запятой в введенном тексте



Вы находитесь на странице вопроса "Составить подпрограмму которая из матрицы F(k,m) K меньше либо равно 25,m меньше или равно 20 удаляет строку, содержащую минимальный элемент всей", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.