Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

необходимо оклеить обоями комнату с заданными величинами длины и высоты стен. также заданы длина, ширина и цена одного рулона обоев. подсчитать суммарные

10-11 класс

расходы в денежном выражении.

Azzyazzy 03 мая 2015 г., 7:34:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Arxiv26
03 мая 2015 г., 9:11:56 (9 лет назад)

var a,b,c,m,l,s1,s,k:real;
begin
write('Длина, ширина и высота комнаты: ');
readln(a,b,c);
write('Длина, ширина и цена одного рулона: ');
readln(l,m,s1);
k:=2*(a+b)*c/m/l;
if k-int(k)>0 then k:=k+1;
k:=int(k);
s:=s1*k;
writeln('Потребуется рулонов: ',k);
writeln('Стоимость покупки: ',s)
end.

+ 0 -
Charlie117
03 мая 2015 г., 12:09:07 (9 лет назад)

тема: Линейные алгоритмы

Ответить

Другие вопросы из категории

Читайте также

Помогите составить алгоритм:Помогите составить алгоритм: Требуется рассчитать необходимое кол-во рулонов обоев для оклейки комнаты.Заданы параметры

комнаты а,b,h.Заданы параметры рулонов обоев длина l,ширина-d,считаем что S окон и дверей составляет 15 % от площади стен.

Задача на C++.

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.

Задание Определить, изделия какой из двух групп товаров выгоднее сшить из одного рулона ткани, если известны: расход ткани на каждое изделие и цена

готового изделия, количество метров в рулоне. Помогите, нужно написать программу решения этой задачи в Паскале

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)



Вы находитесь на странице вопроса "необходимо оклеить обоями комнату с заданными величинами длины и высоты стен. также заданы длина, ширина и цена одного рулона обоев. подсчитать суммарные", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.