Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПОМОГИТЕ СОСТАВИТЬ ПРОГРАММУ. ЗАРАНЕЕ СПАСИБО!!! Дано натурально число n.верно ли, что в записи числа три раза встречается цифра 5?

5-9 класс

Anny7 08 окт. 2015 г., 12:34:02 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Egor1Egor
08 окт. 2015 г., 15:01:01 (8 лет назад)

program msd;
uses crt;
var a,k,i,l:LONGINT;
begin
clrscr;
readln(a);
while true do
begin
l:=a mod 10;
a:= a div 10;
if l = 5 then k:=k+1;
if a = 0 then break;
end;
if k = 3 then writeln('DA')
eLSe WRITeLN('NeT');
ReADKeY;
eND.

Ответить

Другие вопросы из категории

Введите с клавиатуры число х.Определите, является ли данное число дробным.

Пример ввода:3.5
Пример вывода:Число дробное

Имеется источник воды, колличество воды в нем неограниченно, и три ёмкости.Объем емкости А равен 3 л.,емкости В-5 литров, а в емкости С-11 л.Надо получить

4л в емкости В,изпользовав минимальное колличество воды.Пожалуйста решите!!Желательно по быстрее!

помогите по 6 заданию построить таблицу

какие там столбцы нужно?

Читайте также

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.

ПОЖАЛУЙСТА ПОМОГИТЕ СОСТАВИТЬ ПРОГРАММУ И БЛОК-СХЕМУ.

Срочно надо программу надо на Паскале
дано натуральное число n. вычислить s=1*2+2*3*4+...+n*(n+1)*...*2n
Заранее очень благодарна

Помогите написать программу которая по данному натуральному числу от 1 до 2 (номеру месяца) выдает все приходящихся на этот месяц праздничные

дни(например, если введено число 1, то; 1 января - новый год , 7 января - Рождество).



Вы находитесь на странице вопроса "ПОМОГИТЕ СОСТАВИТЬ ПРОГРАММУ. ЗАРАНЕЕ СПАСИБО!!! Дано натурально число n.верно ли, что в записи числа три раза встречается цифра 5?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.