Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Преобразовать строку S следующим образом: заменить все вхождения 'ab' на '*'. Напишите пожалуйста программу для Паскаль или лазарус

10-11 класс

Eeevvvggg 20 марта 2016 г., 4:29:27 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alena12va
20 марта 2016 г., 4:59:52 (8 лет назад)

program gt;
var s:string;
i,l,n:longint;
begin
readln(s);
n:=length(s);
l:=1;
while L<>0 do
begin
l:=pos('ab',s);
if(l<>0)then begin
s:=copy(s,1,l-1)+'*'+copy(s,l+2,n);
n:=length(s);
end;
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

1. Назовите процедуру

ввода информации.

Дано 3-х значное число 121,разбить его на три числа 1,2,1
Для кодирования некоторой последовательности, состоящей из букв А Б В Г и Д решили использовать не равномерный двоичный код, позволяющий однозначно

декодировать двоичную последовательность, позволяющуюся на приёмной стороне канала связи. Для букв А Б В Г используютя такие кодовые слова А=100 Б=101 В=111 Г=110

Каким из перечисленных ниже кодом может быть закодирова буква Д

Код должен удовлетворять свойству однозначного декодирования. Если можно использовать более одного кодового слова, укажите кратчайшее из них

1)000

2)10

3)11

4)1111

Пожалуйста с подробным объяснением. Заранее спасибо

На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И,

К. По каждой дороге можно двигаться только в одном направлении,
указанном стрелкой. Сколько существует различных путей из города А в
город К?

Что такое Microsoft ZAW:

1) Нет такого

2) Zona Application Work - система зонального распределения памяти при работе приложений

3) Zero Administration for Windows, идея Microsoft по внедрению систем, для администрирования которых не нужно прилагать лишних усилий

4) Новая операционная система для на ладонных компьютеров

Читайте также

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ массива В ПАСКАЛЕ, ПОЖАЛУЙСТА)

Дан массив х[N]. Найти наибольший элемент (max). Преобразовать исходный массив таким образом,чтобы все элементы по модулю не равные MAX заменялись нулями,а остальные единицами.

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "Преобразовать строку S следующим образом: заменить все вхождения 'ab' на '*'. Напишите пожалуйста программу для Паскаль или лазарус", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.