Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1. Назовите процедуру

10-11 класс

ввода информации.

Trubenkovairin 17 марта 2016 г., 20:27:32 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Маришка98
17 марта 2016 г., 21:05:16 (8 лет назад)

 Read ввод 
 ReadLn ввод с переводом курсора на следующую строчку

+ 0 -
Sergofan4ik
17 марта 2016 г., 22:23:33 (8 лет назад)

Операция присваивания

+ 0 -
Dasha234632
17 марта 2016 г., 23:48:47 (8 лет назад)

В паскале?

+ 0 -
Вика2223
18 марта 2016 г., 0:52:51 (8 лет назад)

да

Ответить

Другие вопросы из категории

Дано 3-х значное число 121,разбить его на три числа 1,2,1
Для кодирования некоторой последовательности, состоящей из букв А Б В Г и Д решили использовать не равномерный двоичный код, позволяющий однозначно

декодировать двоичную последовательность, позволяющуюся на приёмной стороне канала связи. Для букв А Б В Г используютя такие кодовые слова А=100 Б=101 В=111 Г=110

Каким из перечисленных ниже кодом может быть закодирова буква Д

Код должен удовлетворять свойству однозначного декодирования. Если можно использовать более одного кодового слова, укажите кратчайшее из них

1)000

2)10

3)11

4)1111

Пожалуйста с подробным объяснением. Заранее спасибо

На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И,

К. По каждой дороге можно двигаться только в одном направлении,
указанном стрелкой. Сколько существует различных путей из города А в
город К?

Что такое Microsoft ZAW:

1) Нет такого

2) Zona Application Work - система зонального распределения памяти при работе приложений

3) Zero Administration for Windows, идея Microsoft по внедрению систем, для администрирования которых не нужно прилагать лишних усилий

4) Новая операционная система для на ладонных компьютеров

Помогите в задачами по VBA

Читайте также

Описать процедуру SortInc3(A,

B, C), меняющую содержимое переменных A, B, C таким
образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,
C — вещественные параметры, являющиеся одновременно входными и
выходными). С помощью этой процедуры упорядочить по возрастанию два данных
набора из трех чисел: (A1, B1, C1) и (A2, B2, C2).

Написать программу по ПРОЦЕДУРАМ с массивами в языке программирования Pascal.

Задание:
Дан массив целых чисел. Найти сумму положительных нечетных. Обязательно по процедурам с массивами

С.Р.О.Ч.Н.О. Составить процедуру, вичисляющую значение TRUE, если в первом из двух заданных одномерных массивов количество

отрицательных элементов окажется больше, чем во втором, и значение FALSE в противном случае. Использовать такую процедуру для массивов: R = (0; 0.005; -0.02; -87.5; 50) W = (45; 721.5; 8.63; -76.97; 3)

C.Р.О.Ч.Н.О.

ПАСКАЛЬ.Срочно.Не могу нормально оформить вывод переменной которая высчитывается в процедуре.Как правильно это сделать?При таком раскладе выводит ноль,

хотя если вывод поставить в процедуру тогда все нормально.
program kr_pr_4;

procedure fgerona(a,b,c:real);
var
p,s:real;
begin
p:=(a+b+c)/2;
s:= sqrt(p*(p-a)*(p-b)*(p-c));

end;

var
a,b,c,s,p:real;
begin
writeln('Введите сторону А');
read(a);
writeln('Введите сторону B');
read(b);
writeln('Введите сторону C');
read(c);
fgerona(a,b,c);
writeln('S = ',s);
end.

Тест по паскалю!!!

100. Назовите все отличия функций от процедур?
а) функция передает в точку вызова скалярное значение, а процедура - нет
б) имя процедуры может состоять из трех символов, а функция - нет
в) процедура имеет структуру, повторяющую структуру программы, а в функции отсутствует блок описания переменных
г) имя функции может входить в выражении как операнд

101. С помощью каких параметров происходит передача данных из главной программы в подпрограмму?
а) фактических
б) формальных
в) неформальных
г) подпрограммных

102. Выберите неправильную форму записи оператора цикла
а) WHILE I<5 DO I:=I+1
б) WHILE I<5 DO BEGIN I:=I+1; WRITELN(I); END
в) WHILE I<5 TO BEGIN I:=I+1; WRITELN(I); END

103. Какое выражение обеспечивает генерирование случайных чисел в диапазоне [4,10[
а) 4+RANDOM(6)
б) 6+RANDOM(4)
в) RANDOM(4,6)

104. что означает FV в команде read(FV, x1, x2,..., xn) в Паскале ?
а) формат ввода
б) переменную, связанную с файлом, откуда берется информация
в) фиксированную величину
г) первую переменную величину для ввода информации

105. Каким окажется результат выполнения следующего фрагмента кода X:= 5; Y:= X+1; Writeln('Х=',X, Y=',Y);?
а) X=6 Y=5
б) X=5 Y=5
в) X=5 Y=6

106. Какое значение примет переменная Х после выполнения команды X:=SQR(4)/2*2?
а) 4
б) 2
в) 16

107. Каким окажется результат выполнения следующего фрагмента кода: X:= 5; Y:= 8; Т:= Х; X:=Y; Y:= T; Writeln('Х=', X, Y=',Y);?
а) X=5 Y=8
б) X=8 Y=5
в) X=5 Y=5

108. Логическое выражение
(N Mod 10 Mod 2) Or (N Div 10 Mod 10 Mod 2 = 0) Or (N Div 100 Mod 2 = 0)
должно принимать значение TRUE тогда и только тогда, когда истинно высказывание
а) в трёхзначном натуральном числе все цифры чётные
б) в трёхзначном натуральном числе одна чётная цифра
в) в трёхзначном натуральном числе две чётных цифры
г) в трёхзначном натуральном числе хотя бы одна чётная цифра

109. Цикл в фрагменте программы P := 4; Repeat P := P * 0.1 Until P < 0.0001; будет исполнен?
а) 0 раз
б) 1 раз
в) 4 раза
г) 5 раз

110. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) -1
б) False
в) True
г) 0

111. Значения переменных a и b после выполнения следующих действий
a := 15 Div (16 Mod 7); b := 34 Mod a * 5 - 29 Mod 5 * 2;
будут равны
а) a = 1, b = 160
б) a = 1, b = 4
в) a = 7, b = 25
г) a = 7, b = 22

112. Во фрагмент алгоритма, печатающий все двузначные числа, в записи которых есть цифра N или сумма цифр которых равна самим числам, нужно вписать логическое выражение
а) (P1 = N) Or (P2 = N) And (S = K)
б) (P1 = N) Or (P2 = N) Or (S = K)
в) (P1 = N) And (P2 = N) Or (S = K)
г) ((P1 = N) Or (P2 = N)) And (S = K)

113. Тело цикла в программе a := 1; b := 1; While a + b < 8 Do begin a := a + 1; b := b + 2 end;
выполнится?
а) 1 раз
б) 2 раза
в) 3 раза
г) бесконечное число раз

114. Задана строка St (см Фрагмент алгоритма)
а) определяет количество цифр в строке
б) подсчитывает количество нулей в строке
в) определяет сумму номеров позиций в строке, где стоят цифры
г) подсчитывает сумму цифр в строке;

115. Задан двумерный массив X[1..n, 1..m]. Процедура
а) к элементам столбцов в первой половине матрицы прибавляет элементы первого столбца соответствующей строки
б) добавляет к матрице еще M столбцов с элементами, равными соответствующим элементам первого столбца
в) к элементам четных столбцов прибавляет элементы первого столбца соответствующей строки
г) к элементам четных строк прибавляет элементы первой строки соответствующего столбца;

116. Задан двумерный массив X[1..n, 1..m]. Функция возвращает значение
а) True, если все элементы массива ненулевые
б) True, если в массиве есть элемент, равный нулю
в) False, если в массиве есть элемент, равный нулю
г) Not t;

117. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) 1
б) False
в) True
г) 0

118. В каком фрагменте программы подсчитывается сумма элементов квадратной матрицы, расположенных выше главной диагонали?

а) For i:= 1 to n do
For j:= 1 to n do
If i<=j then
S:=s+a[I,j];

б) For i:= 1 to n do
For j:= i+1 to n do
S:=s+a[I,j];

в) For i:= 1 to n do
For j:= 1 to n do
If i>j then
S:=s+a[I,j];




Вы находитесь на странице вопроса "1. Назовите процедуру", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.