Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Описать процедуру SortInc3(A,

10-11 класс

B, C), меняющую содержимое переменных A, B, C таким
образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,
C — вещественные параметры, являющиеся одновременно входными и
выходными). С помощью этой процедуры упорядочить по возрастанию два данных
набора из трех чисел: (A1, B1, C1) и (A2, B2, C2).

Lili708 12 февр. 2015 г., 21:32:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Timytiboss
12 февр. 2015 г., 22:43:08 (9 лет назад)

procedure SwapInc(var a, b: real);
begin
  a := a + b;
  b := a - b;
  a := a - b;
end;

procedure SortInc3(var a,b,c: real);
begin
  if a > b then SwapInc(a,b);
  if b > c then SwapInc(b,c);
  if a > b then SwapInc(a,b);
end;

var a,b,c: real; i: integer;
begin
  for i := 1 to 2 do begin
    write ('a', i, '='); readln(a);
    write ('b', i, '='); readln(b);
    write ('c', i, '='); readln(c);
    SortInc3(a, b, c);
    writeln(a, ' ', b, ' ', c);
  end;
end.

Ответить

Другие вопросы из категории

С полный объяснением пожалуйста

Определить, кто из четырех подозреваемых участвовал в ограблении банка, если известно:
1) если А участвовал, то и В участвовал;
2) если В участвовал, то и С участвовал, или А не участвовал;
3) если D не участвовал, то А участвовал, а С не участвовал;

1)Представьте двоичное число 11011,11 в четырехбайтовом формате.Представьте число сначала в формате с плавающей запятой. 2)Представьте число

1110,101 в четырехбайтовом формате.Представьте число сначала в формате с плавающей запятой.

4. Вычислить значения выражений:

a. (1 v 0) ^ (1 ^ a)
b. ((1 v 0) ^ (1 ^ 0)) v (0 v 1)
c. a ^ 0 v 1 v a
d. (a v 1) v (b v 0)
e. a ^ 1 v (a v 1) ^ 0

Читайте также

Описать процедуру SumDigit(N,S), находящую сумму

цифр S целого числа N (N — входной, S — выходной
параметр). Используя эту процедуру, найти суммы цифр пяти данных чисел.

Написать программу по ПРОЦЕДУРАМ с массивами в языке программирования Pascal.

Задание:
Дан массив целых чисел. Найти сумму положительных нечетных. Обязательно по процедурам с массивами

С.Р.О.Ч.Н.О. Составить процедуру, вичисляющую значение TRUE, если в первом из двух заданных одномерных массивов количество

отрицательных элементов окажется больше, чем во втором, и значение FALSE в противном случае. Использовать такую процедуру для массивов: R = (0; 0.005; -0.02; -87.5; 50) W = (45; 721.5; 8.63; -76.97; 3)

C.Р.О.Ч.Н.О.

ПАСКАЛЬ.Срочно.Не могу нормально оформить вывод переменной которая высчитывается в процедуре.Как правильно это сделать?При таком раскладе выводит ноль,

хотя если вывод поставить в процедуру тогда все нормально.
program kr_pr_4;

procedure fgerona(a,b,c:real);
var
p,s:real;
begin
p:=(a+b+c)/2;
s:= sqrt(p*(p-a)*(p-b)*(p-c));

end;

var
a,b,c,s,p:real;
begin
writeln('Введите сторону А');
read(a);
writeln('Введите сторону B');
read(b);
writeln('Введите сторону C');
read(c);
fgerona(a,b,c);
writeln('S = ',s);
end.



Вы находитесь на странице вопроса "Описать процедуру SortInc3(A,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.