Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

С.Р.О.Ч.Н.О. Составить процедуру, вичисляющую значение TRUE, если в первом из двух заданных одномерных массивов количество

10-11 класс

отрицательных элементов окажется больше, чем во втором, и значение FALSE в противном случае. Использовать такую процедуру для массивов: R = (0; 0.005; -0.02; -87.5; 50) W = (45; 721.5; 8.63; -76.97; 3)

C.Р.О.Ч.Н.О.

Victori500 07 мая 2013 г., 16:02:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Света04
07 мая 2013 г., 19:01:49 (10 лет назад)

Program Pr1;
uses crt;
const
R:array[1..5] of real =(0,0.005,-0.02,-87.5,50);
W:array[1..5] of real = (45,721.5,8.63,-76.97,3);
var a:boolean;
i,b,t:integer;
Begin
clrscr;
a:=TRUE;
b:=0;
t:=0;
for i:=1 to 5 do begin
if R[i]<0 then b:=b+1;
if W[i]<0 then t:=t+1;
end;
if b>t then writeln(a)
else begin
a:=FALSE;
writeln(a);
end;
end.

Ответить

Другие вопросы из категории

Помогите составить блок схему к задачи Pascal

program sdasdas;
var
a:array [1..10] of integer;
p,i:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(495)+5;
p:=1;
begin
for i:=1 to 10 do
if (a[i] mod 3=0) or (a[i] mod 9=0) then p:=p*a[i];
writeln('Произведение =',p);
end;
readln;
end.

Ввести с клавиатуры три числа (x,y,z). Если x<y<z, то все числа удвоить.

Если z<y<x, то максимальное число возвести в квадрат. Если числа не
удовлетворяют ни одному из условий – обнулить их.

Читайте также

Помогите, пожалуйста, программисты. Basic Составьте подпрограмму, изменяющую одномерный массив чисел делением его

положительных элементов на свои индексы и определяющую число измененных
элементов. Используя эту процедуру, определите, в каком из двух заданных
одномерных массивов А или В больше измененных элементов, а также выведите
измененные массивы А и В. Если же число измененных элементов одинаково, то
выведите соответствующее сообщение

Составить процедуру для нахождения номера элемента наибольшего и наименьшего

элементов одномерного массива. Используя эту процедуру, поменять местами в строке
наибольший и наименьший элементы соответственно с первым и последним элементом
строки.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Помогите, пожалуйста!!!

Составить программу на языке Турбо-Паскаль, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: Данные числа x, y являются координатами точки, лежащей в первой координатной четверти



Вы находитесь на странице вопроса "С.Р.О.Ч.Н.О. Составить процедуру, вичисляющую значение TRUE, если в первом из двух заданных одномерных массивов количество", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.