Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дано трехзначное число найдите модуль разности между этим числом и числом составленным из тех же цифр но взятых в обратном порядке

5-9 класс

Ales1213224345 07 дек. 2016 г., 5:51:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tishka5
07 дек. 2016 г., 6:52:38 (7 лет назад)

var a,b,r:integer;
begin
readln(a);
b:=strtoint(reversestring(inttostr(a)));
r:=abs(a-b);
writeln(r);
end.

+ 0 -
Adelia1605
07 дек. 2016 г., 7:30:06 (7 лет назад)

Если не нужно поразить учителя своими глубокими познаниями, то вот вариант более примитивной программы)))
var    
   x,y,z:integer;
   s:string;
begin
readln(x);
s:=IntToStr(x);
s:=s[3]+s[2]+s[1];
y:=StrToInt(s);
z:=abs(x-y);
writeln(z)
end.
Программа написана только для данной задачи - трехзначного числа!

Ответить

Другие вопросы из категории

Программист Василий Кардов недавно получил банковскую карточку. Чтобы не забыть пароль к карточке, Василий решил построить его по алгоритму, а именно:

пароль равен количеству чисел от 1 до 10000, НЕ делящихся на 13 и 17. Чему равен пароль васи?

Составить блок схему со стрелочками к программе: Program name; const n=30; var a:array [1..n] of integer;

vari,r:integer;

begin

for i:=1 to n do

begin

a[i]:=random (20);

write (a[i],' ');

end;

r:=0;

for i:=1 to n do

if a[i]<10 then r:=r+1;

writeln;

writeln ('kolichestvo chisel menshe 10 - ',r);

end.

Читайте также

Помогите пожалуйста решить задания:

1) Преобразуйте двоичное число в восьмеричное:1010100
2)Преобразуйте двоичное число в десятичное:100010
3)Преобразуйте двоичное число в шестнадцатеричное:1110001000
4)Преобразуйте восьмеричное число в двоичное:67
5)Преобразуйте восьмеричное число в десятичное:207
6)Преобразуйте восьмеричное число в шестнадцатеричное: 2246
7)Преобразуйте десятичное число в двоичное:404
8)Преобразуйте десятичное число в восьмеричное:283
9)Преобразуйте десятичное число в шестнадцатеричное:1001
10)Преобразуйте шестнадцатеричное число в двоичное:5D
11)Преобразуйте шестнадцатеричное число в восьмеричное:4C
12)Преобразуйте шестнадцатеричное число в десятичное: 35B

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

помогите решить задачи по информатике (на уровне знаний 7 класса) с помощю PascalABC

1. Дано 2 числа найти модуль разности этих чисел увеличенный в 5 раз.
2. Дано 4 значное число поменять местами 1 и 2 цифру местами
3. Дан диаметр круга найти его площадь (формула S=п*R).
Я примерно знаю как писать но всеровно нуждаюсь в помощи
Мои мысли:
program z1;
uses crt;
var ... : integer;
begin
дальше всё в тумане
буду рад за решённые 1 или 2 задачи



Вы находитесь на странице вопроса "дано трехзначное число найдите модуль разности между этим числом и числом составленным из тех же цифр но взятых в обратном порядке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.