Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста написать программу на паскале: Вычислить значение последовательности S=(1+1)/(1+2)+(2+1)/(2+2)+(3+1)/(3+2)+...+(n+1)/(n+2).

10-11 класс

KUEkaterinago 07 сент. 2013 г., 22:23:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kekse51020
07 сент. 2013 г., 23:50:50 (10 лет назад)

var a,b,n,i :integer;
s,k:real;
begin
readln(n);
for i := 1 to n do
begin
a := i + 1;
b := i + 2;
k:=a/b;
s:=s + k;
end;
write(s);
end.

+ 0 -
Abdulhamidovas
08 сент. 2013 г., 0:22:10 (10 лет назад)

от скольки до скольки программа должна выполняться?

+ 0 -
мальвинка1
08 сент. 2013 г., 3:19:00 (10 лет назад)

или какое максимально число имеет Н

+ 0 -
Ютюшка
08 сент. 2013 г., 5:49:30 (10 лет назад)

или число Н вводиться с клавиатуры?

+ 0 -
Inna0807
08 сент. 2013 г., 7:24:04 (10 лет назад)

Да n ddjlbncz c клавиатуры,может быть любым числом,программа выполняется n раз но каждый раз увеличиваются числа на 1:(1+1)/(1+2)+(2+1)/(2+2)+(3+1)/(3+2) и тд.

Ответить

Другие вопросы из категории

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом. Напечатать все слова, предварительно преобразовав каждое из них по следующему правилу: удалить из слова все последующие вхождения первой буквы

Помогите написать код программы в Pascal для задачи:

дано натуральное число n среди чисел 1,2 ... n найти все те, которые можно представить в виде суммы квадратов двух натуральных чисел.
Заранее огромное спасибо!!

Где ошибка?? const n=10; type TMas=array[1..n] of integer; var mas1:TMas; procedure ImputMas1(var masTMas: integer);

var i: integer;

begin for i:=1 to 10 do

begin

mas1[i]:=random(n);

Write(mas1[i]:3);

end;

end.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите, пожалуйста написать программу на паскаль

Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).



Вы находитесь на странице вопроса "Помогите пожалуйста написать программу на паскале: Вычислить значение последовательности S=(1+1)/(1+2)+(2+1)/(2+2)+(3+1)/(3+2)+...+(n+1)/(n+2).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.