Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

РЕБЯТКИ СРОЧНО ПОМОГИТЕ СДЕЛАТЬ ПРОГРАММУ (ТОЧНО ПО ЗАДАНИЮ) И БЛОК СХЕМУ.

10-11 класс

Blak7raven 17 окт. 2014 г., 14:07:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladjuha007
17 окт. 2014 г., 15:22:32 (9 лет назад)

const
  m = 4;
  n = 3;

var
  z: array[1..m, 1..n] of integer;
  x: array[1..n] of real;
  i, j, s: integer;

begin
  Randomize;
  Writeln('Массив Z');
  for i := 1 to m do
  begin
    for j := 1 to n do
    begin
      z[i, j] := Random(101) - 50;
      Write(z[i, j]:4)
    end;
    Writeln
  end;
  Writeln('Массив X');
  for j := 1 to n do
  begin
    s := 0;
    for i := 1 to m do s := s + z[i, j];
    x[j] := s / m;
    Write(x[j]:0:2, ' ')
  end;
end.

Тестовое решение:
Массив Z
  10 -32 -21
 -49  15  38
  11  19   9
  31 -26 -34
Массив X
0.75 -6.00 -2.00

Блок-схема находится во вложении.

Ответить

Другие вопросы из категории

с появлением мобильной связи люди начали задавать вопрос, который раньше не задавали .Это вопрос

а) как дела?

б) когда увидимся

в) что делаешь?
г) ты где?

1.Для работы с отдельными елементами таблицы их необходимо..

а) изъять. б)выделить в)переместить г)скопировать

Турис идет к озеру у развилки дорог сидят 2 брата каждый из которых знает какая дорога ведет к озеру на вопросы братья отвечают только да или нет 1 из

них всегда гооврит правду, а другой лжет необходимо сформулировать вопрос чтобы турист нашел дорогу к озеру!

Читайте также

Определить для массива X(n) алгебраические суммы четных и нечетных элементов массива. Вывести исходный массив и полученные значения. Упорядочить массив X(n

) по возрастанию. Вывести полученный массив. Исходный массив элементов получить с помощью датчика случайных чисел. Значения буквенных переменных задавать с клавиатуры.
Помогите написать программу в QBasic и нарисовать блок-схему(необязательно)

алгоритм Мишень цел n, k, i вещ массив P[1000] вещ r1, r2 начало ввести

n, массив P и радиусы r1, r2 /* Исходные данные */

вывести заголовок задачи и значения n, P, r1, r2 k ¬0 для i от 1 до n шаг 1 выполнять/*

Подсчитать число точек */ если r1 < ri и ri < r2 то k ¬k +1

конец-если

конец-цикл

вывести заголовки выходных данных и значений k конец

Теперь спланируем тестирование.

Проверку программы выполним при следующих исходных данных.

Зададим число точек на плоскости: n = 10. Подберем расстояния и радиусы: 0.03 21.0 12.89 7.41 99.99

P = 12.34 56.78 90.98 7.6 0.54

r1 = 12.35 r2 = 56.90.

Выходные данные в этой задаче будут иметь вид: Мишень Исходные данные:

n= 10 Массив P[n]: 0.03 21.0 12.89 7.41 99.99 12.34 56.78 90.98 7.6 0.54 r1 = 12.35 r2 = 56.90

Ответ: внутри 3 точки (три точки находятся внутри кольца).помогите написать программа в паскале и алгоритм блок-схему.пожалуйста срочно!

нарисуйте блок схему по листингу задачи.Даша Пупырышкина изучает английский язык во втором классе. Ей задали домашнее задание: переписать

английские слова, записанные строчными буквами, в тетрадь. Выполняя задание, она комментирует его. Даша произносит слово "Опять" каждый раз, когда пишет букву, которая уже встречалась в слове раньше.
Составьте программу, которая по слову определяет: сколько раз Даша произнесёт "Опять".
Примеры:
Исходное слово apple Ответ 1 раз
Исходное слово potato Ответ 2 раза
Ваша программа должна
Запросить слово;
Подсчитать сколько раз, переписывая это слово, Даша произнесёт "Опять" и вывести это число на экран.



program dasha;
var s: string;
x, l, i, y, j: byte;
begin
writeln('введите слово');
readln(s);
l := length(s);
y := 0;
for i:=1 to 1-1 do
for j:=i+1 to l do
if (s[i] = s[j]) then y := y+1;
writeln('Даша скажет опять', y, ' раз');
end.

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.



Вы находитесь на странице вопроса "РЕБЯТКИ СРОЧНО ПОМОГИТЕ СДЕЛАТЬ ПРОГРАММУ (ТОЧНО ПО ЗАДАНИЮ) И БЛОК СХЕМУ.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.