Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Пожалуйста, напишите программы и по возможности начертите блок-схемы.

10-11 класс

Tatjana27 31 янв. 2015 г., 2:24:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Merry8547
31 янв. 2015 г., 4:50:48 (9 лет назад)

1)
var  x: real;
begin 
writeln('Введите x:'); 
readln(x); 
if (x = 0) or (x = -0.5) then writeln('Значение функции не определено')
  else  if x < -1 then writeln('y=', 3 * x / (2 * x * x + x))
    else  if x > 9 then writeln('y=', 2 - power(x, 3) + 4 * x)
        else writeln('y=', 8)
end.

2)
var  x: real;
begin 
writeln('Введите x:'); 
readln(x); 
if (x = 0) or (x = 0.5) then writeln('Значение функции не определено')
  else  if x < 3 then writeln('y=', 3 * x / (2 * x * x - x))
    else  if x > 9 then writeln('y=', 2 - power(x, 3) + 4 * x)
       else writeln('y=', 8)
end.

+ 0 -
Leroynex
31 янв. 2015 г., 6:16:02 (9 лет назад)

Покажи несколько блок-схем, чтобы знать, какие обозначение вы используете, а то все по-разному делают

Ответить

Другие вопросы из категории

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Сделайте пожалуйста блок-схему или код в small basic. Дан массив из 20 целых чисел. В массиве хранятся результаты соревнований по спортивной стрельбе.

Один элемент массива соответствует количеству очков, набранных одним участником соревнований, и имеет значение от 0 до 30 включительно. Необходимо разработать программу, которая по данным массива вычисляет максимальное количество очков среди участников соревнований, и количество участников набравшее зачётное количество очков. Зачётное количество очков 18. Гарантируется, что хотя бы один участник соревнований набрал зачётное количество очков.



Вы находитесь на странице вопроса "Пожалуйста, напишите программы и по возможности начертите блок-схемы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.