Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана матрица 5х5. Найти сумму элементов,лежащих под главной диагональю квадратной матрицей С. Найти вектор, составленный из сумм по столбцам матрицы.

10-11 класс

Нужно составить программу в QBasic

Azanov 06 апр. 2016 г., 7:07:58 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vallil16
06 апр. 2016 г., 9:11:20 (8 лет назад)

DIM A(5, 5)
RANDOMIZE TIMER
FOR I = 1 TO 5
    FOR J = 1 TO 5
        A(I, J) = INT(RND * 10)
        IF J < I THEN S = S + A(I, J)
        A(0, J) = A(0, J) + A(I, J)
        PRINT A(I, J); " ";
    NEXT J
    PRINT
NEXT I
PRINT "SUM="; S
PRINT "VECTOR: ";
FOR I = 1 TO 5
    PRINT A(0, I); "; ";
NEXT I

Ответить

Другие вопросы из категории

для каких марок автомобилей ЛОЖНО высказывание

Заканчивается на согласную в слове 6 букв четвёртая буква гласная
1ауди
2мазда
3мерседес
4ниссан
5субару
6митсубиши

Протабулировать

функцию у = sin(x+

Читайте также

Задача Pascal

Найти наименьшие элементы в каждом столбце матрицы Х(5,5) и переписать их в одномерных массив А.В массиве А вычислить сумму элементов,стоящих на четных местах и произведение элементов,стоящих на нечетных местах.Массив А,сумму и произведение вывести на экран

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "Дана матрица 5х5. Найти сумму элементов,лежащих под главной диагональю квадратной матрицей С. Найти вектор, составленный из сумм по столбцам матрицы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.