Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано натуральное число. Найти число, получаемое из

10-11 класс

исходного перестановкой его первой и последней цифр.Написать программу в среде devc++ или c++, пожалуйста люди.

Lerakharina03 09 мая 2016 г., 13:48:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darinavorobishek
09 мая 2016 г., 14:44:52 (7 лет назад)

Данная задача достаточно легко реализуется с помощью строкового типа.

#include <iostream>
#include <string.h>
int main() {
  char number[1000]; std::cin >> number;
  int first = number[0]; int second = number[strlen(number)-1];
  number[0]=second; number[strlen(number)-1]=first;
  std::cout << number;
  return 0;
}

Ответить

Другие вопросы из категории

Читайте также

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Даны 3 числа.Найти минимальное из них


Вы находитесь на странице вопроса "Дано натуральное число. Найти число, получаемое из", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.