Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПАСКАЛЬ! 1. Подсчитать среднее арифметическое натуральных чисел, принадлежащих диапазону от 1 до N

5-9 класс

Natanikiforova 30 июня 2013 г., 6:03:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Trk6
30 июня 2013 г., 6:34:51 (10 лет назад)

const
  k = 15;

var
  x: array[1..k] of integer;
  i, n, m: integer;

begin
  Randomize;
  Write('Введите значение N -> ');
  Readln(n);
  Write('Элементы массива: ');
  m := 0;
  for i := 1 to k do
  begin
    x[i] := Random(n + 1) + 1;
    m := m + x[i];
    Write(x[i]:4);
  end;
  Writeln;
  Writeln('Среднее арифметическое равно ', m / k:0:4)
end.

Тестовое решение:

Введите значение N -> 50
Элементы массива:   22  31   1  35  18  41   1  35  46  12  48  27  35  37  29
Среднее арифметическое равно 27.8667


+ 0 -
Ivag2000
30 июня 2013 г., 8:16:56 (10 лет назад)

Т.е. К случайных чисел из диапазона [1;N], или набор натуральных 1,2,3,...N ?

+ 0 -
Пони678
30 июня 2013 г., 10:09:44 (10 лет назад)

случайных

Ответить

Другие вопросы из категории

Пожалуйста помогите! Ответьте пожалуйста на вопросы по информатике! Тема: "Что такое информация"

1) Какие бывают виды информации?
2) Какие бывают действия с информацией?
3) Где храниться информация?
4) Какие бывают носители информации?
5) Как передается информация?

помогите,

нужно нарисовать елочку в программе кумир, с помощью чертёжника
просто напишите алгоритм

Вождь племени Мульти поручил своему министру разработать двоичный код и перевести в него важную информацию. Какой разрядности

потребуется двоичный код, если алфавит. используемый племенем Мульти, содержит 64 символа! решение с Дано

Читайте также

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму

двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

исло M называется средним арифметическим двух чисел A и B, если M равно (A + B) / 2. Васе на день рождения подарили два числа A и B. Именинник легко

вычислил их среднее арифметическое и так обрадовался, что потерял число B. Помогите Васе восстановить потерянное число.

ПОМОГИТЕ НАПИСАТЬ ХОТЯ БЫ ОДНУ ЗАДАЧУ НА Pascal ОНИ НЕ СЛОЖНЫЕ , А Я ДАЮ МНОГО ПУНКТОВ!! За 2 лучший ответ! Без плагиата! 1.Написать

программу,используя оператор цикла While,которая будет вводить целые положительные числа не превышающие 100. Найти сумму квадратов чисел 2.Написать программу используя оператор цикла Repeat,которая будет вводить целые числа до тех пор пока не будет введён 0.Подсчитать среднее арифметическое введённых чисел.

В ПАСКАЛЕ!№1 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить сколько среди них чисел, кратных 4; №2 С клавиатуры вводятся 10

натуральных двузначных чисел. Определить

среднее арифметическое нечетных чисел;

№3 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить

верно ли, что среди введенных чисел есть число, в котором первая цифра в два раза больше последней.



Вы находитесь на странице вопроса "ПАСКАЛЬ! 1. Подсчитать среднее арифметическое натуральных чисел, принадлежащих диапазону от 1 до N", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.