Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Дано трехзначное число. Написать программу (Pascal), которая «переставляет» первую цифру числа

10-11 класс

на самое последнее место.

SUPERSTEPANOVIK 02 окт. 2013 г., 17:31:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Artemon0000
02 окт. 2013 г., 18:20:54 (10 лет назад)

uses crt;
var a: integer;
begin
     readln(a);
     a:=(a div 10 mod 10)*100+(a mod 10)*10+(a div 100);
     writeln(a);
end.

Ответить

Другие вопросы из категории

#include

<iostream>


using namespace
std;


int main(){
int a = 2;

По какой из масок каталога отображена указанная группа файлов

Группа файлов

1)cabinda.xls

2) cubic.xlsx

3) irbic.xls

4) tobias.xls

Маски

1) ??bi*.xls

2) ??bi*.xls*

3) **bi*.xls*

4) ??bi*.x*

Пожалуйста поподробнее. Заранее спасибо

Читайте также

написать программу(pascal) которая вводит с клавиатуры числа А,B,C. найти на сколько увеличится за А лет

B рублей положенная в банк если годовая прибыль составляет С процентов. (используя только mod div. 1 курс корочи) заранее спасибо

Написать программу Паскаль))) срочно!)))

Ввести с клавиатуры натуральное число.написать программу, которая определяет, кратна ли сумма его цифр 6.

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.



Вы находитесь на странице вопроса "1. Дано трехзначное число. Написать программу (Pascal), которая «переставляет» первую цифру числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.