Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решите,проверьте в паскале и только потом отправляйте.

5-9 класс

Создайте массив из n
элементов (1 < n < 20) и найдите произведение всех его элементов.
Элементы массива вводятся генератором случайных чисел.

DrFynth 04 окт. 2013 г., 23:24:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KetSima2012
05 окт. 2013 г., 1:27:53 (10 лет назад)

var
  a: array [1..20] of integer;
  i, n: integer;
  k: longint;
begin
  k := 1;
  readln(n);
  for i := 1 to n do
  begin
    a[i] := random(10);
    write(a[i], ' ');
  end;
  writeln();
  for i := 1 to n do
    k := k * a[i];
  writeln(k);
end.

+ 0 -
Magic2004
05 окт. 2013 г., 3:17:52 (10 лет назад)

const
  n = 20;

var
  i: integer;
  a: array[1..n] of integer;
  p: real;

begin
  Randomize;
  p := 1;
  for i := 1 to n do
  begin
    a[i] := Random(21) - 10;
    p := p * a[i]
  end;
  writeln('Произведение всех элементов равно ', p:0:0)
end.

Тестовое решение:

Произведение всех элементов равно -15431472000000


Ответить

Другие вопросы из категории

У исполнителя Утроитель две команды, которым присвоены номера: 1. умножь на 3, 2. вычти 2. Первая из них увеличивает число на экране в 3 раза, вторая

уменьшает его на 2. Запишите порядок команд в программе преобразования числа 3 в число 23, содержащей не более 4 команд, указывая лишь номера команд. (Например, 21211 -- это программа умножь на 3 прибавь 1 умножь на 3 прибавь 1 прибавь 1, которая преобразует число 1 в 14.) (Если таких программ более одной, то запишите любую из них Можно с объяснением

В двумерном массиве Z[1..5,1..5] найти наименьший элемент среди элементов вспомогательной диагонали. вывести на экран его индексы и значение.

Пожалуйста, не используйте заумных проограмм, составьте её для Паскаля на уровне 9 класса. Большое спасибо.

что такое макет слайда?

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

Помогите, пожалуйста, решить задачу на паскале. Срочно.

Даны два натуральных числа m и n. (m,n ≤ 9999). Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n.



Вы находитесь на странице вопроса "Решите,проверьте в паскале и только потом отправляйте.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.