Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

в ПАСКАЛЕ.

10-11 класс

строка содержит одно слово. является ли оно палиндромом?
ПОМОГИТЕ ПЛИЗ!

Ulmart34589 27 окт. 2014 г., 1:14:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AlaDop
27 окт. 2014 г., 3:10:19 (9 лет назад)

var
    s: string;
    i: integer;

begin
    read(s);
    s := trim(s);
    for i := 1 to length(s) div 2 do
        if s[i] <> s[length(s) - i + 1] then begin
            writeln('Не палиндром');
            exit;
        end;
    writeln('Палиндром');
end.

Ответить

Другие вопросы из категории

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два

целых числа N и K (1 <= N <= 10^100, 1 <= K <= 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.txt): 239 16 Пример выходного файла (output.txt): 15

Устройство, предназначенное для согласования кабеля и предотвращающее появление отраженного сигнала, подсоединяемое на концах шины и к незанятым разъемам

пассивного разветвителя.


1) терминатор

2) активатор

3) концентратор

4) адаптер

5) коннектор

В книге 100 страниц на каждой странице случайное число строк от 35 до 45. на каждой строке буква А встречается случайное число раз от 2 до 5. сколько раз

буква А встречается в книге. Написать программу в Паскале. Помогите пожалуйста

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "в ПАСКАЛЕ.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.