Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

. Если целое число m делится нацело на целое число n, то вывести на экран частное от деления, в противном случае вывести сообщение вида m на nнацело

5-9 класс

не делится.
P.S -в школе делали через Кмир

Tatyana56rus 30 дек. 2014 г., 2:08:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna11222
30 дек. 2014 г., 4:33:37 (9 лет назад)

var m,n:integer;
begin
readln(m,n);
if (m mod n)=0 then
write(m div n) else
writeln(m,' на ',n,' нацело не делится.');

Ответить

Другие вопросы из категории

составить программу. помогите пожалуйста

ввести возраст человека (от 1 до 150) и вывести с последующими словами "год", "года", "лет"

I=4бита

Найти N
Нужна помощь..

Читайте также

Программа по информатике,Программа по информатике, помогите!Программа по информатике, помогите! Имеется n банок с целочисленными объемами

v1, v2, v3..., vn литров, пустой сосуд и кран с водой. Можно ли с помощью этих банок налить в сосуд ровно v литров воды.(Ответ должен выдаваться да или нет) Решение: обозначим s:=nod(v1, v2, v3..., vn) Если v делится нацело на s, то в сосуд с помощью банок можно налить v литров воды, иначе нет.Напишите программу пожалуйста,срочно и полностью, я вообще её не могу понять,помогите!!! :)

Найдите выведите на экран все трехзначные числа,кратные 20,сумма цифр которых равны сумме цифр частного от деления их на 20 Может так

>

uses crt;
var b,c,d,t,i,s,k:integer; o:real;
begin
s:=0;
for k:=100 to 1000000000 do
begin
b:=k mod 10;
c:=k div 100;
d:=(k mod 100)div 10;
t:=d+b+c;
o:=(b div 20)+(c div 20)+(d div 20);
if ((k mod 20)=0) and (t=o) then s:=s+1;
end;
writeln('s=',s);
end.

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].



Вы находитесь на странице вопроса ". Если целое число m делится нацело на целое число n, то вывести на экран частное от деления, в противном случае вывести сообщение вида m на nнацело", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.