Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Паскаль. задается последовательность натуральных чисел. Найти среднее арифметических всех отрицательных чисел

10-11 класс

BobEgor2 06 июня 2013 г., 3:34:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Чайка2012
06 июня 2013 г., 6:10:45 (10 лет назад)

Решение #1

 

var a:array[1..1000] of integer;

s,i,k,N:integer;

begin

s:=0;

k:=0;

read(N);

for i:=1 to N do

read(a[i]);

for i:=1 to N do

if a[i]<0 then begin

s:=s+a[i];

k:=k+1;

end;

writeln(s/k);

end.

 

Решение #2;

 

var a,i,s,k,N:integer;

begin

k:=0;

s:=0;

read(N);

for i:=1 to N do begin

read(a);

if a<0 then begin

k:=k+1;

s:=s+a;

end;

end;

write(s/k);

end.

 

Оба решение дают один результат, но первое сделан массивом, а второе простым перебором чисел.

 Формат входных данных

Задается натуральное число N

Затем задается N целых чисел 

Формат выходных данных

 Целое число - среднее арифметическое всех отрицательных чисел

 Пример

Вход

5

1 -2 3 -4 5

Выход

-3

 Вопросы в ЛС

Ответить

Другие вопросы из категории

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

помогите 14, пожалуйста

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.



Вы находитесь на странице вопроса "Паскаль. задается последовательность натуральных чисел. Найти среднее арифметических всех отрицательных чисел", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.