Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1 задача.

10-11 класс

Сколько существует целых
положительных чисел, меньших 512₁₀,
в двоичной записи которых
встречается не менее шести единиц подряд?
В ответе укажите целое число.

Dianalatypova2 29 янв. 2015 г., 22:39:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gop645
30 янв. 2015 г., 0:25:20 (9 лет назад)

program gt;
var a:array[1..100]of integer;
k,q,p,i,max:integer;
begin
for i:=1 to 512 do
begin
p:=i;
max:=0;
K:=0;
while p>0 do
begin
q:=p mod 2;
p:=p div 2;
if(q=1)then k:=k+1;
if(q=0)then begin
if(k>max)then max:=k;
k:=0;
end;
end;
if(max>=6)then writeln(i);
end;
end.
191
319
382
383
447
2)
размер 512 байт /c*64c=

Ответить

Другие вопросы из категории

Программа.Матрица. Паскаль.

как получить матрицу такого вида в паскале?
1 1 1 1 1...

1 2 3 4 5 ...

1 3 6 10 15...

1 4 10 20 35...

...

1 столбик и первая строчка равны 1
последующ. получаются путем сложения верхнего и стоящего слева цисел...


Читайте также

Задача первая.

Дан массив O ( K ). Заменить все положительные числа квадратом числа,а отрицательные модулем.
Задача вторая.
Дан массив R ( 6 ) .Найти сумму и произведение всех элементов массивов.

Через Qbasic

ОТ CLS ДО ЕND

Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.

задача. даны площади нескольких квадратов. найти длину диагонали самого большого из них.



Вы находитесь на странице вопроса "1 задача.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.