Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача D Три числа Дан массив из N целых чисел а1, а2, ...,

10-11 класс

an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Yanaernest 27 мая 2015 г., 12:29:41 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sokolik8
27 мая 2015 г., 15:08:06 (8 лет назад)

 Program esep;
var i,j,k,n,sum:integer;
 input,output:text;
a:array[1..100] of integer;
flag:boolean;
begin flag:=false;
Assign(Input,'d.in');
reset(input);
readln(input,n);
assign(output, 'd.out');
rewrite(output);
writeln('Input elements');
readln (n);
for i:=1 to n do read(a[i]);
for i:=1 to n do 
for j:=1 to n do 
for k:=1 to n do 
if (i<>j) and (j<>k) and (i<>k) then
 if a[i]+a[j]+a[k]=0
then
begin
writeln (output,'Yes');
flag:=true;
halt;
end;
if flag=false then writeln(output,'No');
close(input);
close(output);
end.

+ 0 -
Tanjushka80
27 мая 2015 г., 16:00:51 (8 лет назад)

ЛЮДИ БУДТЕ ДОБРЫ ПОМОГИТЕ МНЕ РЕШАТ ЭТУ ЗАДАЧВУ ОЧЕНЬ ПРОЩУ ВАС

Ответить

Другие вопросы из категории

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Задача D Три числа Дан массив из N целых чисел а1, а2, ...,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.