Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить программу. Найти сумму элементов K 16 массива

10-11 класс

Kira109 29 апр. 2015 г., 6:52:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daneckecka
29 апр. 2015 г., 8:28:48 (9 лет назад)

const k = 16;
var
  a: array[1..k] of integer;
  s, i: integer;
begin
  for i := 1 to k do begin
    a[i] := random(50);
    write(a[i], ' ');
    s := s + a[i];
  end;
  writeln; writeln(s);
end.

+ 0 -
Emalnov9027
29 апр. 2015 г., 9:46:08 (9 лет назад)

 

Ручной ввод массива

Program sum;

 uses crt;

 const n=16;

 Var summa,i:integer;

     k:array[1..n] of integer;

Begin

For i:=1 to n do

 Begin

  Write('Элемент массив № ',i, ' = ');

  Readln(k[i]);

 End;

For i:=1 to n do

   Summa:=summa+k[i];

 Writeln('Сумма элементов массива равна ', summa);

End.

 

Случайный ввод массива

Program sum;

 uses crt;

 const n=16;

 Var summa,i:integer;

     k:array[1..n] of integer;

Begin

For i:=1 to n do

 Begin

K[i]:=random(1001)-500;

  Writeln('Элемент массив № ',i, ' = ',k[i]);

End;

For i:=1 to n do

   Summa:=summa+k[i];

 Writeln('Сумма элементов массива равна ', summa);

End.

Ответить

Другие вопросы из категории

В задаче на двумерный массив сделать файловый вывод. Вот само решение задачи.

var a:array[1..12,1..10] of integer;
i,j:integer;
begin
for i:=1 to 10 do
a[1,i]:=i*12;
for i:=2 to 12 do
for j:=1 to 10 do
a[i,j]:=a[i-1,j]-1;
for i:=1 to 12 do begin
for j:=1 to 10 do
write(a[i,j]:4);
writeln;
end;
end.

Решите в паскале ABC .

Известно время полета вылета самолета - HH часов и ММ
минут, а также продолжительность полета (НР часов и МР минут). Напечатать время
прибытия самолета в аэропорт назначения в виде: самолет прибывает в
12.35. Учесть возможность перехода часов (после 23.59 наступает 00.00).

Для передачи по каналу связи сообщения, состоящего только из символов А, Б, В и Г, используется посимвольное кодирование: А – 00, Б – 11, В – 010, Г –

011. Через канал связи передаётся сообщение: ВБГАГВ.Закодируйте сообщение данным кодом. Полученное двоичное число переведите в шестнадцатеричный вид.

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE



Вы находитесь на странице вопроса "составить программу. Найти сумму элементов K 16 массива", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.