Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана матрица размерности N на M. Положительные элементы матрицы переписать подряд в одномерный массив В Помогите плиз

10-11 класс

Chekryshovaale 05 марта 2017 г., 19:51:52 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dsvir
05 марта 2017 г., 22:16:00 (7 лет назад)


program Project1;
{$APPTYPE CONSOLE}
uses SysUtils;
var A:array of array of Integer;
  B:array of Integer; i,j,N,M,t:Integer;
begin { TODO -oUser -cConsole Main : Insert code here } t:=0;
while not (N in [1..100]) do begin write('N = ');
    readln(N);
end;
while not (M in [1..100]) do begin write('M = ');
    readln(M);
end; SetLength(A,N,M);
  Writeln('Matrix is - ');
for i:=0 to N-1 do begin for j:=0 to M-1 do begin A[i,j]:=Random(30)-10;
      write(A[i,j],' ');
if A[i,j]>=0 then begin SetLength(B,t+1);
        B[t]:=A[i,j]; Inc(t);
end;
end;
    Writeln;
end; Write('Massive B = ');
for i:=0 to t-1 do write(B[i],' ');
  A:=nil;
  B:=nil;
  readln;
end.

Ответить

Другие вопросы из категории

Незнайка насобирал корзину грибов: 30 подосиновиков и несколько лисичек. выберите, какое количество грибов (подосиновиков и лисичек), из ниже

перечисленных чисел унего могло быть, если известно, что "(ЛИСИЧЕК НЕ БОЛЬШЕ, ЧЕМ ПОДОСИНОВИКОВ) И (ЛИСИЧЕК БОЛЬШЕ 15)"?

Составить программу, которая утроит искомый символ. на паскале

то есть вместо 1 будет писать 111

Читайте также

найти максимальный по значению элемент матрицы x (n,m) (n<=10,m<=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое

положительных элементов матрицы. полученную матрицу x и среднее арифмитическое распечатать

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

Дана вещественная квадратная матрица А порядка n. Найти среднее

арифметическое среди положительных элементов матрицы, находящихся на
главной и побочной диагоналях. Выдать сообщение, если таких элементов нет.



Вы находитесь на странице вопроса "Дана матрица размерности N на M. Положительные элементы матрицы переписать подряд в одномерный массив В Помогите плиз", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.