Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана строка текста. Слова в тексте друг от друга отделяются одним пробелом. Вставить после каждого слова запятую.

10-11 класс

Pinirob 09 июня 2014 г., 23:45:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NastyClever
10 июня 2014 г., 2:20:21 (9 лет назад)

var

  s, r : String;

  i : Integer;

begin

  r := '';

  Writeln('Введите строку:');

  Readln(s);

 

  while s[i] <> #0 do

  begin

    if s[i] = ' ' then r:= r + ',';

    r := r + s[i];  

end; 

 

 Writeln(r);

 Readln; 

end.

+ 0 -
вор777
10 июня 2014 г., 3:50:09 (9 лет назад)

Простите, но в чем суть задания? Что делать? Поясните по-человечески 

Ответить

Другие вопросы из категории

Какой объем видеопамяти необходим для хранения двух страниц изображения при условии,что разрешающая способность дисплея равна 800*600 пикселей,а

количество используемых цветов- 256? Выразите полученный результат в Кбайтах.

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом. Напечатать все слова, отличные от последнего слова.

Нерввы на пределе, завтра сдавать, а в процедуре организовать не получается... Составить программу для решения следующей задачи: Дана строка.

Зашифровать ее, переворачивая каждое слово. Создать процедуры для разбиения строки на слова и записи слова в обратном порядке.

Привет, Вася!

!ясаВ ,тевирП



Вы находитесь на странице вопроса "Дана строка текста. Слова в тексте друг от друга отделяются одним пробелом. Вставить после каждого слова запятую.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.