Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано натуральноe n, посчитать сумму n и вывести результат на экран. s=1+1/2+1/3+1/4+1/5+1/6+...n. Написать программу а Pascal с помощью цикла с преду

5-9 класс

словием.

Nargiza789 24 сент. 2014 г., 20:04:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
дааама
24 сент. 2014 г., 20:59:41 (9 лет назад)

program kokoko;
uses crt;
var i,n:integer;
k:real;
begin
i:=0;
k:=0;
writeln('Введите число n')
;
read(n);

while i<=n do
begin 
i:=i+1;  // как счетчик и кол-во раз прибавления
k:=k+(1/i);
end;
writeln('Ответ ',k:2:2); // циферки после к значат что будет 2 знака после за
end.

Ответить

Другие вопросы из категории

Текст рассказа набран на компьютере. Информационный обьём получившегося файла 9 Кбайт. Текст занимает 6 страниц, на каждой странице одинаковое количество

строк, в каждой строке 48 символов. Все символы представлены в кодировке КОИ-8, в которой каждый символ кодируется 8 битами. Определите, сколько строк помещается на каждой странице.

Люди сделайте срочно надо срочно до завтра .

Является ли условным оператором последовательность символов?
a)if x б)if x>=y then x:=0; y:=0 else write (z)
в)if x Заранее Спасибо.

Читайте также

Дано словесное описание алгоритма: z:=2; d:=7; k=0; Начало цикла пока d>=z

d:=d – z; k=k+1;

конец цикла;

Вывести результат на экран.

Составить блок-схему в виде циклического алгоритма. Определить количество циклов k. Написать программу на языке Паскаль с использованием оператора цикла с предусловием.

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.



Вы находитесь на странице вопроса "Дано натуральноe n, посчитать сумму n и вывести результат на экран. s=1+1/2+1/3+1/4+1/5+1/6+...n. Написать программу а Pascal с помощью цикла с преду", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.