Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Введите цену трех товаров и напечатать цену самого дешевого товара

5-9 класс

Настя4527 13 нояб. 2014 г., 22:49:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iisha
14 нояб. 2014 г., 0:04:39 (9 лет назад)

program af;

uses crt;

var x,y,z:integer;

begin

clrscr;

readln(x,y,z);

if  (x<y)and(x<z) then writeln(x)

else

if (y<x)and(y<z) then writeln(y)

else

if (z<x)and(z<y) then writeln(z);

readln;

end.

Ответить

Другие вопросы из категории

Pascal Проверить присутствие в массиве вещественных чисел отрицательных элементов, квадрат которых больше 100. Ограничения: -число

элементов в матрице не более 10-ти

Порядок ввода исходных данных:

-число элементов в массиве

-элементы массива

Порядок вывода результатов:

-сообщение Элементы найдены или Элементы не найдены.

Читайте также

Циклические конструкции

1) написать программу, которая выводит на экран таблицу с числами от 1 до 10 их квадратами и квадратным корнем (цикл с параметром)
Введите цену одного килограмма и нажмите enter (копейка от рубля отделается точкой
Число Квадрат числа. Корень квадрата
1. 1. 1
2. 4. 1.41
3. 9. 1.73
И тд

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

В таблице Dat хранятся цены в рублях за 10 видов товаров(Dat[1] - оценка за первый вид товара, Dat[2] - за второй и т.д.). Определите что будет

напечатано в результате выполнения следующего алгоритма, записанного на трёх алгоритмаических языках.



Вы находитесь на странице вопроса "Введите цену трех товаров и напечатать цену самого дешевого товара", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.