Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Семьдесят два балла за простое задание! Сделайте по-нормальному, пожалуйста.

5-9 класс

Написать программу для вычисления корней квадратного уравнения: ax^2+bc+c=0.

Olgaosovskaya19 13 февр. 2015 г., 1:14:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лова15
13 февр. 2015 г., 3:04:31 (9 лет назад)

var a,b,c,d,x1,x2:real;
begin
writeln('Введите коэффициент a');
readln(a);
writeln('Введите коэффициент b');
readln(b);
writeln('Введите коэффициент c');
readln(c);
d:=sqr(b)-4*a*c;
if d>0 then 
begin
x1:= ((-1)*b+sqrt(d))/(2*a);
x2:=((-1)*b-sqrt(d))/(2*a);
writeln('x1=',x1,' x2=',x2);
end
else if d=0 then
begin
x1:= ((-1)*b)/(2*a);
writeln('x=',x1);
end
else writeln('Корней нет');
end.

Ответить

Другие вопросы из категории

Действие компьютерного вируса состоит в том, что вместо букв «б», «в», «л», «о», «т» печатаются цифры, причём разным буквам соответствуют разные цифры

кроме цифры 0 причем разным буквам соответствуют разные цифры.Выясните какие цифры соответствуют,если сумма цифр «бот»=8 сумма цифр«вол»=9 сумма цифр болт=11 сумма цифр лото=12

срочно!!помогите!!

ответить на тест
1.в ячейку введены символы СУММ(G4:H5).КАК Excel воспримет эту информацию?
а)формула---с)текст
б)ошибка---д)число
2.в ячейки F6,F7,G6,G7 введены соответств.числа:10,3,4,2..в ячейке введена формула =СУММ(F6:G7).КАКОЕ ЧИСЛО БУДЕТ В ЯЧЕЙКЕ H5?
А)19---с)7
б)15---д)5
3.в ячейки B4,B5,C4,C5 введенЫ соответств. числа:10,7,6,5.в ячейку введена формула =СРЗНАЧ(В4:С5).Какое число будет в ячейке С7?
а)2---с)15
б)7---д)28
4.выберите верную запись формулы для электронной таблицы
а)С3+4*D4---с)А5В5+23
б)С3=С1+2*С2---д)=А2*А3-А4
5.В ячейку Е2 введена формула =С2+D1.Содержимое Е2 скопировали в ячейку Е6.какая формула буде в Е6?
а)=С5+D4---c)=C7+D6
б)=С6+D5---д)=С4+D3
6.при перемещении или копировании в электронной таблице абсолютные ссылки
а)преобразуются вне зависимости от нового положения формулы
б)не изменяются
с)преобраз.в зависимости от нового положения формулы
д)преобраз.в зависимости от правил,указанных в формуле
7.в каком адресе не может меняться номер столбца
а)13S--c)H42
б)Z$9---д)$S35
8/При перемещении или копировании в электр таблице относит ссылки
а)преобраз вне зависимости от нового положения формулы
б)преобраз в завис от длины формулы
с)не изменяются
д)преобраз. в зависимости от нового положения формулы

РЕшить задачу через FOR и WHILE

Читайте также

Ребят сделайте пожалуйста с помощью программы Паскаль задания номер 7.и задание номер 5. Завтра сдавать д.з а у меня программа не работает(( решите и

пришлите решение задач!..Даю хорошие баллы за это задание.Всем большое спасибо!

Найдите значение логического выражения (X<3) & (X<2) для указанных значений числа X:

P.S.(над скобками стоит инверсия тоесть отрицания скобки 1 и 2 инверсия стоит отдельно на каждой скобке, если знаете ответ не пишите его тупо сразу а объясните как получилось, отдам 70 баллов!!!!! мало кто предложит 70 за простое задание!!!
1)1
2)2
3)3
4)4
?????????????????????
помогите плиииииз завтра надо отдать!!!!!!!!!!

ребят, помогите пожалуйста, ну ооочень нужно, от этого зависит аттестуют меня или нет, заданий правда много, и пожалуйста, не пишите херню либо очень

мало
эти задания нужно сделать циклами while и for, т е чтобы получилось 12 программ

1. Составьте программу вычисления значения функции: y=7x^2+1/x^2-16
2. Составьте блок-схему алгоритма и программу расположения четырех чисел в порядке возрастания.
3*. Составьте программу, определяющую вид треугольника по трем его сторонам A, B, C.

4. Составьте блок-схему алгоритма и программу вывода на экран всех трехзначных чисел, кратных 7.
5. Составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел, кратных 13.
6*. Составьте программу вывода на экран таблицы степеней 2ⁿ, где 0 ≤ n ≤ 10.

я вас просто умоляю, напишите, пожалуйста

Ав­то­мат по­лу­ча­ет на вход два дву­знач­ных де­ся­тич­ных числа. По по­лу­чен­ным чис­лам стро­ит­ся новое де­ся­тич­ное число по сле­ду­ю­щим

пра­ви­лам.
1. Вы­чис­ля­ют­ся два числа — сумма цифр пер­во­го числа и сумма цифр вто­ро­го числа.
2. По­лу­чен­ные два числа за­пи­сы­ва­ют­ся друг за дру­гом в по­ряд­ке не­убы­ва­ния (без раз­де­ли­те­лей).

При­мер. Ис­ход­ные числа: 73 и 45. Сумма цифр пер­во­го числа: 10, сумма цифр вто­ро­го числа: 9. Ре­зуль­тат: 910.

Опре­де­ли­те, сколь­ко из при­ведённых ниже чисел могут по­лу­чить­ся в ре­зуль­та­те ра­бо­ты ав­то­ма­та:

211 1717 1817 1718 1719 219 21 10

В от­ве­те за­пи­ши­те толь­ко ко­ли­че­ство чисел.

Помогите сделать по информатике задание :

Закончите определения .
а) Информатика - это наука ______________________________________________________________________________________________________________________________________________________________
б) География - это наука _____________________________________________________________________________________________________________________________________________________________
в) Фонетика - это раздел науки о _________________________________________________________________________________________________________________________________________________________
г) Ботаника - это раздел науки о __________________________________________________________________________________________________________________________________________________________
д) Имя существительное - это самостоятельная часть речи , __________________________________________________________________________________________________________________________________________________________
е) Глагол - это самостоятельная часть речи , __________________________________________________________________________________________________________________________________________________________
ж) Земледельцы - это люди , _________________________________________________________________________________________________________________________________________________________
з) Животноводы - это люди , __________________________________________________________________________________________________________________________________________________________
и) Тяжёлая промышленность - это _________________________________________________________________________________________________________________________________________________________
к) Лёгкая промышленность - это _________________________________________________________________________________________________________________________________________________________
Мне обязательно сделать под буквами д , е , ж ( желательно ) , з , и , к . Сделаете хотябы под этими буквами , обязательно поставлю на лучший ( если найду конечно ) !



Вы находитесь на странице вопроса "Семьдесят два балла за простое задание! Сделайте по-нормальному, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.