Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1задача напишите программу на языке паскаля плииз

10-11 класс

Sinonim147 28 сент. 2013 г., 7:02:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Foton77
28 сент. 2013 г., 8:48:24 (10 лет назад)

uses crt;
var a: array [1..1000,1..1000] of integer;
     m,n,b,c,x,y,p:integer;
begin
     writeln('Введите количество столбцов и строк исходной матрицы');
     write('b='); readln(m);
     write('c='); readln(n);
     for b:=1 to m do begin
         for c:=1 to n do begin
             a[b,c]:=random(90)+10;
             write(a[b,c]:3);
         end;
         writeln;
     end;
     writeln('Введите номера столбцов, которые нужно поменять');
     write('x='); readln(x);
     write('y='); readln(y);
     for b:=1 to m do
         begin
                  p:=a[b,x];
                  a[b,x]:=a[b,y];
                  a[b,y]:=p;
         end;
     for b:=1 to m do begin
         for c:=1 to n do
                  write(a[b,c]:3);
         writeln;
         end;
end.

Ответить

Другие вопросы из категории

Пожалуйста,помогите решить

1.Укажите через запятую в порядке возрастания все основания систем счисления,в которых запись числа 29 оканчивается на 5.
2.В системе счисления с некоторым основанием десятичное число 129 записывается как 1004.укажите это основание.


Под конфигурацией ЭВМ понимают

1) ПК и монитор

2) тип микропроцессора, объем ОЗУ и емкость HDD

3) Принципы выполнения операций: последовательный, параллельный, конвейерный и другие

4) конкретный набор устройств ЭВМ

5) тип компьютера: ПК, рабочая станция, сервер, HOST

Помогите решить

1.Чему равна переменная D при обработке следующего кода: D:= 0; For i = 1 to 5 do D= D+ i

Еще одну!! Пожалуйстаааааа

Читайте также

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!



Вы находитесь на странице вопроса "1задача напишите программу на языке паскаля плииз", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.