СРОЧНО!!! ОТКЛИКНИТЕСЬ, ИНФОРМАТИКИ! Дан одномерный массив из 10 элементов. Заполнить его случйным образом. Найти количество тех элементов, значения
10-11 класс
|
которых меньше 20 и кратны заданному числу С. Программу можно, ПОЖАЛУЙСТА? :)


program abc;
var a:array[1..10] of integer;
i,j,c:integer;
begin
writeln('Введите С='); readln(c);
for i:=1 to 10 do begin
a[i]:=random(100);
write(a[i]:3);
if ((a[i]<20) and (a[i] mod c = 0)) then inc(j);
end;
writeln('Кол-во тех элементов=',j);
end.
Другие вопросы из категории
[1..7] программа должна выдать сообщение об ошибке
Читайте также
элементов.Найти колличество четных положительных элементов.
3)Дан массив из 6 элементов.Найти произвдение положительных из них.
индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы
языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.
среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива
номера дней, когда температура опускалась ниже -10. Напишите программу, которая позволяет найти и вывести номера дней, когда температура опускалась ниже -10.