Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Вычисление чисел Фибоначчи (паскаль)

10-11 класс

А[1]=1
А[2]=1
А[3]=2
А[4]=3
А[5]=5
А[6]=8

иголачка 09 авг. 2016 г., 22:44:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Saulenko97
09 авг. 2016 г., 23:16:46 (7 лет назад)

Program Fib;
var a:array [0..100] of integer;
      i,n:integer;
      begin
              a[1]:=1;
              a[2]:=1;
              for i:=3 to 100 do
              begin
              a[i]:=a[i-1]+a[i-2];
               Write('a[',i,'] = ',a[i],'   ');
               end;
      end.         

Ответить

Другие вопросы из категории

Рассеянный программист во многих

словах допускает ошибки, однажды он писал другу, что хочет поменять свой
компьютер на более мощный с новым устройством для вычислений и обработки
информации и подумал, что написал название этого устройства. Однако, его друг в
письме, прочел слово, обозначающее ученую степень, и не понял, что подразумевал
наш программист. А какое же слово программист хотел написать?

Microsoft access это что

Читайте также

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.

Решить на C#, используя циклы. Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощь

ю следующих рекуррентных соотношений f_{1}=f_{2}=1, f_{n}=f_{n-1}+f_{n-2}, n\geq3, где f_{n} - целое. Отследить корретность ввода исходных данных.

Числа Фибоначчи – элементы числовой последовательности 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987, 1597, 2584, 4181, 6765,

…, в которой каждое последующее число равно сумме двух предыдущих чисел. Количество простых чисел среди первых сорока пяти чисел Фибоначчи составляет …

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Вычисление чисел Фибоначчи (паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.